Excel: Daten zu Tageszeiten (in 5min-Schritten) auf Zeitsplate mit 1min-Schritten übertragen?

... komplette Frage anzeigen

2 Antworten

wenn Dich auch nur jeder 5.Wert interessiert, dann (die 1-min-Werte stehen in A, der Oberste sagen wir mal A3, auslesen nach zB B4 (aber allgemein formuliert):

=INDIREKT("A"&((ZEILE(B4)-ZEILEN(B$1:B$3))*5)-2)

A=auszulesende Spalte

B=auslesende Spalte (im Prinzip bedeutungslos, welche), aber Zeile(B4)=4

Zeilen(B$1;B$3) Zeilen oberhalb der ersten Formel (beachte $, da Konstante:=3

5: Du wolltest jede 5. Zelle auslesen

-2: das erste Produkt ergibt 5 (denn eine Zeile(B0) kann man nicht berechnen), der erste Wert steht aber 2 Zeilen oberhalb von 5

Wenn Du die anderen Werte mitverhackstücken willst, zB Mittelwerte bilden bei Zahlen oder Texte aneinanderhängen bei Zeichenfolgen) dann frag in dieser AW nochmal nach!

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
29.08.2016, 16:08

Die AW von Maximus hat mich erst draufgebracht:

ich bin davon ausgegangen, dass Du die Liste auf 1/5 schrumpfen wolltest und dass Du nicht die Zeit runden wolltest (deren Abstände ja im fixen 1-min-Takt je Zeile vorliegen), sondern den zugehörigen Wert auslesen?

Kopiere die Formel in die Spalte rechts neben den auszulesenden Werten, damit sie sich nicht mehr auf Spalte A bezieht, sondern eben auf die gewünschte (A und B hab ich ja relativ gelassen).

Hast Du da keinen Platz, so verschiebe  (nicht kopiere!) die erste Formel in der gleichen Zeile entsprechend weit nach rechts und kopiere sie dann nach unten). Notfalls musst Du am Zielort erst einen anderen Wert in einer freien Zelle "Zwischenlagern", den Du hinterher wieder zurückschieben kannst.

0

Geht ganz einfach:

nehmen wir an, die Zeit, die du runden willst, steht im Feld B4. Dann schreibst du im Feld daneben (C4) folgendes rein:

=RUNDEN(B4*24*60/5;0)*5/24/60

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von IchundmeinHandy
29.08.2016, 15:15

Hallo, danke für die schnelle Antwort! Ich verstehe nur nicht ganz, wie Du das meinst mit runden? Ich möchte ja quasi, dass er mir durchlaufend in einer 1min-getaktentablle die Werte aus der 5min-getakteten überträgt. Nur für den Fall, dass ich falsch verstanden wurde.

0

Was möchtest Du wissen?