Excel Daten automatisch verändern - komplette Frage

...komplette Frage anzeigen

3 Antworten

ich hab diese Frage schon im Vorgänger
Excel Daten automatisch verändern
beantwortet, ist vielleicht in dem Durcheinander dort (ist mir auch schon passiert!) untergegangen. hier nochmal der Link:
http://www.gutefrage.net/frage/excel-daten-automatisch-veraendern

mit wechseln dürfte es zwar gehen, aber das muss auch in eine andere Zelle (prinzipiell!) und es ist kaum zu handhaben, wenn Du das an einer bestimmten Stelle machen willst, zB im Zehner:
=Wechseln(A1;"3";"9";1) liedert zwar ein richtiges Ergebnis,für 123,
aber für 133 oder 302 wird die falsche 3 ausgetauscht!. Das letzte Argument n (hier:1) bezieht sich nämlich auf das n-te Auftreten, nicht auf die n-te Position!. Und =Wechseln(A1;"3";"9";3) wechselt nirgends aus ausser in 333.

=links(rechts(A1;1);1) dagegen bezieht sich bei Ganzzahlen eindeutig auf die Einer,
=links(rechts(A1;2);1) dagegen eindeutig auf die Zehnerposition einer glatten Zahl.
=Teil(A1;2;1) bezieht sich nicht auf Einer oder Zehner als solche, sondern auf die zweite Ziffer einer Zahl beliebiger Länge (auch Dezimalzahl)!
Das ist beliebig verkomplizierbar, man könnte so Vor- und Nachkommastellen trennen mit
=finden(",";A1;1), aber das führt hier zu weit.
Weils nichts kostet, hier nochmals die einfache Gesamtformel für die Einerstelle (die 9 ist die Ziffer, die anstatt der Einer-3 eingesetzt werden soll (kann auch eine Bezugszelle sein, in der 9 steht):
=WENN(RECHTS(A1;1)="3";WERT(LINKS(A1;2)&9);".")

die anderen Stellen habe ich in Deiner oben verlinkten Frage behandelt.

0

Ich weiß das wird dir nicht wirklich helfen aber bei meiner Version von Excel ich habe kein MS Excel sondern ein Programmierer Excel da kann man das durch den befehl =[change_3 into("0,1,2,4,5,6,7,8,9")]

Ich versteh das Prinzip noch nicht. Vielleicht erklärst du es mit anderen Worten

Sowas kann man mit Formeln oder wenn es komplexer wird mit einem Funktionsmakro lösen.

Was möchtest Du wissen?