Excel Calc falsche Berechnung und Fehler in Verschachtelte Wenn Formel?

... komplette Frage anzeigen

3 Antworten

A1: a

a in A3 ist ein Text, und der wird von xl als größer gesetzt als jede von xl verarbeitbare Zahl (max 2^1024-1, kann man aber nur ausdrücken als 2^1023+2^1022+2^1021+...)

innerhalb Textvergleichen (auch Bezüge mit Text) funktioniert das allerdings wieder:

"ab">"aa" liefert WAHR


"aba">"ab" liefert WAHR


"ab">"ba" liefert FALSCH

auch Labelzahlen sind Texte:

'1 > 21 liefert WAHR

zu den WENNs hast Du ja schon kompetente Antworten.

Kommentar von Iamiam
21.03.2016, 13:00

="9">"A" liefert FALSCH (da =Code("9") mit 57 kleiner ist als der von "A" (65)

="9">"!" liefert FALSCH (da der Code von "9" größer ist als der von "!" (33),

ebenso =" ">"!" , da das Leerzeichen mit 32 den niedrigsten Code aller Nicht-Steuerzeichen hat

1

Für das äußere WENN hast du keinen Sonst-Zweig angegeben. Lässt man ihn weg, wird standardmäßig FALSCH zurück gegeben, sollte der Fall eintreten.

Kommentar von PWolff
21.03.2016, 12:19

Wenn im Sonst-Fall nichts ausgegeben werden soll, kann man

WENN(Bedingung; Dann-Wert; "")

verwenden. (Wenn man das 2. Semikolon schreibt, das Argument danach aber weglässt, führt das zwar nicht zu einem Fehler, liefert aber 0 statt LEER, wie man erwarten sollte.)

2
Kommentar von hdk43
21.03.2016, 12:22

Der Sonst-Zweig ist vorhanden. Es ist 

=WENN(A5="";WENN(B5>60;"Groß";"")) Ist Falsch

Hinter "Groß" steht ;""

Sonst wüsste ich nicht wie man den Sonst-Zweig eingeben kann.

Auch finde ich unlogisch, dass wenn man =A3>10 eingibt

Siehe Bild 2

                                                              

0
Kommentar von hdk43
22.03.2016, 15:09

Mein Fehler war dieser:

der Sonst Eintrag muss vor der letzten Klammer eingetragen werden

=WENN(A5="";WENN(B5>60;"Groß)");"")

statt

=WENN(A5="";WENN(B5>60;"Groß)";""))

1

Hallo,

wie unser Experte Supobtimierer schon gesagt hat, fehlt der SONST Wert in deiner ersten WENN Funktion

Deine Formel:

=WENN(A4="";WENN(B4>60;"Groß";""))
=WENN(A5="";WENN(B5>60;"Groß";""))

Eine WENN Funktion ist folgendermaßen aufgebaut:

=WENN([Überprüfung];[DANN-Wert];[SONST-Wert])

Du überprüfst:

=WENN(A4=""[Wenn die Zelle A4 Leer ist];WENN[Dann Wenn)) 

und das war es.

Du solltest aber so was versuchen ;)

=WENN(A4=""[Wenn die Zelle A4 Leer ist];""[Dann schreibe nichts];WENN(B4>60[Ansonsten, WENN B4 größer als 60 ist];"Groß"[Schreibe Groß];""[Ansonsten schreibe nichts])))

Das gleiche gilt für die 2. Formel.

Ich hoffe wir konnten helfen :)

Grüße,

iMPerFekTioN

Kommentar von hdk43
22.03.2016, 15:13

Mein Fehler war dieser:

der Sonst Eintrag muss vor der letzten Klammer eingetragen werden

=WENN(A5="";WENN(B5>60;"Groß)");"")

statt

=WENN(A5="";WENN(B5>60;"Groß)";""))

Siehe mein Bild

1

Was möchtest Du wissen?