Excel Buchstaben zusammenzählen?

... komplette Frage anzeigen

4 Antworten

nur dann die Buchstaben "S" in Spalte C zusammenzählen wenn in Spalte B der Buchstabe "H" steht?

=ZÄHLENWENNS(B1:B30;"H";C1:C30;"S")

oder wenn zusätzlich gilt:

geht das auch wenn in einem Feld in Spalte C mehrere Buchstaben stehen?

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*")

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von JackJack11
27.08.2016, 12:16

hab versucht die Formel etwas zu verkomplizieren

ich möchte gerne zusätzlich sagen das es nur die "S" zusammenzählen soll wenn "H" in Spalte B steht und der Wert aus Spalte E größer ist als H4 und kleiner oder gleich groß I4 

kannst du mir bitte sagen wo mein Fehler ist?

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*";E37:E125;">H4";E37:E125;"<=I4")

0
Kommentar von JackJack11
17.09.2016, 00:23

ich wollte eine weitere Bedingung einfügen, jedoch klapp es nicht ganz
einmal die grundformel 

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*")

nun soll gezählt werden wenn D1>E1

=ZÄHLENWENNS(B1:B30;"*H*";C1:C30;"*S*";D1:D30;">"&E1:E30)

wenn ich D30 und E30 weglasse geht es
es soll aber auf die Spalte D und E bezogen sein

wo ist mein Fehler

hab schon einiges ausprobiert aber es will einfach nicht klappen

0

Wie ich es lösen würde:
Ich schreibe in Spalte D eine Funktion, die mir auswertet, ob diese Zeile gezählt werden soll.

etwa

=WENN (UND (C1="S"; B1="H");1;0)

Dann brauchst du nur eine Summe über die relevanten D-Zeilen bilden und hast das Ergebnis.

Antwort bewerten Vielen Dank für Deine Bewertung

Versuch es mit ZÄHLENWENN oder ZÄHLENWENNS.

Antwort bewerten Vielen Dank für Deine Bewertung

Kurz und schmerzlos:

=ZÄHLENWENN(C:C;"*s*")

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?