Excel bedingte Formatierung mit Formel - 2 Werte vergleichen und wenn übereinstimmend + zusätzlich werte > 0 farblich markieren Wie?

...komplette Frage anzeigen

1 Antwort

Der erste Abgleich funktioniert so über bedingte Formatierung
=ZÄHLENWENN(Tabelle2!B$1:B$10;D1)>0

Den Bereich (hier Tabelle2 B1:B10) musst Du anpassen, ich habe nicht genau verstanden, wo gesucht werden soll. Den Gültigkeitsbereich der bedingten Formatierung entsprechend erweitern.

Zum zweiten Abgleich habe ich allerdings nicht nachvollziehen können, was geprüft wird. Ist D1 schon eine Zahl? Dann kann man ja direkt abfragen, ob D1 > 0 ist oder soll irgendein Wert in Spalte B (tabelle2) größer 0 sein?

Die Logik ist mir nicht klar: D1 ist eine Nummer (4711) - die wird in Spalte B gefunden. Damit gibt es ja auf jeden Fall eine Zahl größer 0 mit dem Treffer.

Ansonsten wäre die Abfrage
=ZÄHLENWENN(Tabelle2!B1:B10;">0")

Als bed. Formatierung zusammengesetzt:

=UND(ZÄHLENWENN(Tabelle2!B$1:B$10;D1)>0;ZÄHLENWENN(Tabelle2!B1:B10;">0")>0)

Übrigens, falls die Excel-Version etwas älter ist (ich weiß aber nicht genau bis zu welcher), dann werden in der BF keine Formeln verwendet werden können, die über mehrere Tabellenblätter hinausgehen. Das muss man dann über die Namensvergabe oder die INDIREKT-Krücke umgehen, wie hier beschrieben http://www.excelformeln.de/tips.html?welcher=109

0

Was möchtest Du wissen?