Excel Balken Diagramm erstellen?

...komplette Frage anzeigen

2 Antworten

Bevor Du hier weiter im Nebel rumstocherst:

Diagramme geben in grafischer Form den Inhalt des Tabellenblattes (TabBl) wider.
Diagramme sind nicht in der Lage, Berechnungen vorzunehmen.
D.h. alles, was Du grafisch darstellen willst, muss bereits im TabBl errechnet bzw. dargestellt sein.

Du solltest also erstmal Dein TabBl (oder eine Kopie auf einem weiteren TabBl) so bearbeiten, dass alle in der Grafik anzuzeigenden Werte (Einzel- Gesamtgewichte, ...) vorhanden sind. 

Dann - wenn alle Werte vorhanden sind - kannst Du Dich an die Erstellung der Grafik machen.

Gruß aus Berlin

Schreib einfach am Ende der Spalte "=SUMME(A2:A25)" (z. B.) rein, um die Gewichte zu addieren. Ich glaube allerdings, dass in diesem Fall die verbundenen Zellen nur für die linkeste Spalte zählen, das musst du also vermutlich manuell ändern.
Aus den Ergebnissen kannst du dann ganz einfach ein Diagramm erstellen, so wie du es geschrieben hast.

Das mit den Ursprungs- und Folgeobjekten musst du nocheinmal ein bisschen genauer erklären, ich habe nicht ganz verstanden, was genau du da meinst.

Also du meinst ich soll irgendwo sozusagen unsichtbar ein Feld erzeugen in dem ich die Summe aus allen Werten bilde und diese dann als Balken aufnehmen? Unsichtbar erzeugen im Sinne von weißer schrift auf weißen Hintergrund...

Ok, ich versuche es. Nehmen wir ein Fahrrad. Das Fahrrad ist das gesamte Objekt und besteht aus einzelnen Teilen wie dem Lenker oder den Reifen und dem Sattel. Es gibt bei diesem Objekt in der Entwicklung verschieden Stadien und in diesen Stadien haben vielleicht die Reifen ein anderes Gewicht oder der Lenker weil er zuerst Gummigriffe hat und dann doch Ledergriffe bekommen soll. Oder weil man sich zuerst für eine Stahlstange entscheidet und dann vielleicht doch Alu nimmt in einer anderen Entwicklungsphase. Und diese Entwicklungsphasen will ich dann miteinader vergleichen um aufzeigen zu können welche Gewichtsreduzierung stattgefunden hat.

0
@syprix

Ja, ganz genau.

Ah ok, jetzt verstehe ich dich. Am einfachsten wäre es, denke ich, auch hierfür eine (oder mehrere) eigene Spalten (für jeden Entwicklungsstand eine) und Zellen (für die Differenzen) zu benutzen.
Die Differenzen im gleichen Balken darzustellen, das wird allerdings nicht einfach. Wenn der zweite Wert immer kleiner ist als der erste, dann geht es (du kannst auch erst den kleineren der beiden Werte raussuchen lassen und diesen dann verwenden), aber das funktioniert nicht mehr (schön), wenn der zweite kleiner ist (und wenn du die andere Methode anwendest, dann siehst du zwar immer den Unterschied, aber nicht, welches der beiden der größere Wert ist). Falls du es ausprobieren möchtest: du kannst ein Diagramm erstellen, in dem mehrere Werte hintereinander dargestellt sind. Wähl das aus nimm als Datensätze die kleineren Werte (Formel zum suchen nach dem größeren Wert: "=WENN(A2<B2;A2;B2)") und den Unterschied.
Ansonsten kannst du natürlich jedes Stadium als einzelnen Datensatz benutzen, dann hast du dafür jeweils einen eigenen Balken (oder du nimmst als ersten Datensatz jeweils die linke Seite, als zweiten die rechte, dann hast du immer zwei Balken nebeneinander und mit etwas Abstand die nächsten, die für ein anderes Stadium stehen).

0

Was möchtest Du wissen?