Excel Automatischer Verweis mit Formel oder VBA?

... komplette Frage anzeigen

1 Antwort

Das kannst mit mit INDIREKT lösen, solange B9, B10 genau dem Namen des Tabellenblatts entspricht:

In F2 folgende Formel

=WVERWEIS(D9;INDIREKT("'"&B9&"'!"&"$B$3:$E$5");3;0)

Es ist bei Indirekt wichtig, den Bereich B3:E5 mit "" anzugeben. Da die Tabellenblätter Leerzeichen enthalten, muss man neben dem Namen aus B9 noch die ' rein fummeln.

Mit Trennzeichen, damit es besser lesbar ist:
" ' " &B9&" '! "

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
19.10.2016, 14:43

Ich glaube die Antwort kannst Du vergessen - ich bin bei der Beispieldatei irgendwie darauf verfallen, dass die Tabellenblätter in der Formel dynamisch ermittelt werden sollen. Das finde ich im Fragetext so aber gar nicht wieder.

Was genau heißt für Dich,
"die weiteren Werte für dieses Modul automatisch laden"
Die Spalte Config 1 erhöhen? Das macht der Anwender doch über eine explizite Eingabe. Soll diese wegfallen?
D9ff wäre dann ="Config "&ZÄHLENWENN(B$9:B9;B9)

Fehler muss man aber noch abfangen, denn die Formel zählt sonst beliebig weiter, auch wenn es Config 5 etc. gar nicht gibt.

0

Was möchtest Du wissen?