Excel: Aus Tabelle A etwas in Tabelle B suchen und eine Zelle aus B wiedergeben, kann wer helfen?

...komplette Frage anzeigen

2 Antworten

Hallo, die ERklärung ist leider etwas schwierig nachzuvollziehen.

Kannst du eventuell zeigen, wie du es bisher versuchst?

Du möchtest in Tabelle A etwas drin haben, dieses dann in Tabelle B finden und Spalte M aus Tabelle B wiedergeben?

juhaafrage 29.07.2016, 13:22

=SVERWEIS(E21;infra!A:L;12;WAHR)

so hab ich es bisher. Er gibt mir auch was aus der gesuchten Spalte raus, allerdings was falsches.. Spalte A wurde durch E ersetzt. hab gerade die aus Zeile 21 rauskopiert.Im Prinzip kann da auch E2 stehen

0
juhaafrage 29.07.2016, 13:26
@juhaafrage

die Tabellen sind nicht sortiert, da diese permanent aktuallisiert wird und eine Sortierung nicht sinnig wäre

0

=sverweis(A1;TabelleB!B:M;12;falsch) sollte gehen.

juhaafrage 29.07.2016, 13:23

habs jetzt so =SVERWEIS(E21;infra!A:L;12;WAHR)

die richtige Spalte wird durchsucht, gibt allerdings was falsches wieder. Spalte A wurde durch E ersetzt

0
juhaafrage 29.07.2016, 13:26
@juhaafrage

die Tabellen sind nicht sortiert, da diese permanent aktuallisiert wird und eine Sortierung nicht sinnig wäre

0
Ninombre 29.07.2016, 14:39
@juhaafrage

dann sollte der letzte Parameter aber auf "falsch" stehen, d.h. exakte Suche. Wahr wäre eine ungefähre Suche, die wiederum nur bei sortierten Werten Sinn macht.

0
Ninombre 01.08.2016, 14:26
@juhaafrage

Das heißt, dass der Suchbegriff nicht gefunden wurde. Überprüf mal die Zellformatierungen und -inhalte. Ein Suchbegriff mit und ohne Leerzeichen ist nicht das gleiche auch eine Zahl wird nicht gefunden, wenn sie mal als Zahl und mal als Text formatiert ist. Gerade bei Zahlen darauf schauen, was tatsächlich in der Zelle steht. Über Zellformatierung kann man bspw. runden, so dass oberflächlich eine 2 angezeigt wird, in Wirklichkeit aber 2,01 drin steht.

0

Was möchtest Du wissen?