EXCEL: Alle Zellen eines Bereichs zählen mit Bedingung für zwei zueinander relativen Zellen

...komplette Frage anzeigen

3 Antworten

Geht auch mit Summenprodukt:

=Summenprodukt((A1:A10<>"") * (B1:B10="Inhalt"))

Sozusagen für später mal als Einstieg in Matrixformeln
(als welche Summenprodukt noch nicht erkennbar ist, aber de fakto ist es eine!)

Da kann man praktisch beliebig viele Bedingungen aneinanderhängen, man muss nur immer die gleiche Zellenzahl haben!

Vielen Dank für die rasche Hilfe. Und ebenso für die lehrreiche Diskussion unter Jackies Antwort, das bringt mich weiter. Selbiger Dank natürlich auch an Jackie :)

Viele Grüße

1
@Oolee

Danke für den *, den Jackie genausogut verdient hätte.
Ich nehms gern als Kompensation für Entscheidungen zu meinen Ungunsten in anderen Fragen! Da die *-Bewertungen insgesamt hier Mangelware sind,
-(gibts eine Statistik, wieviel % der Fragen keinen vergebenen * oder überhaupt keine Rückmeldung haben?)-
ist er sehr hilfreich bei der Aufrechterhaltung des Ratgeberhelden-Status.
Auch wenn man davon nicht abbeissen kann, führt er (leider!) doch dazu, dass die Antworten aufmerksamer gelesen, sozusagen mehr ernst genommen werden (Vorschuss-Lorbeeren).
Im Thema Excel gibts überhaupt nur 3 davon, und einer, der mir weit überlegen ist (A-Chris) hat ihn nicht (wahrscheinlich auch noch weitere)!

1
@Iamiam

Hallo Lamiam,

ich kann mich deinem Kommentar voll anschließen. Es ist immer wieder traurig, dass man nicht weiß ob eine Antwort hilfreich war oder der Fragesteller sich selber helfen konnte oder woanders eine Lösung gefunden hat.

1
@dkilli

...oder die Flinte ins Korn geworfen hat, der Kenntnisstand ist ja manchmal katastreophal: Hab heute einen Bekannten am Telefon gehabt dem ich so was einfaches wie Summe erklären sollte,
Nach vielem Hin und Her hat sich dann herausgestellt, dass er -halt die Luft an- "istgleichSumme(..." in die Zelle geschrieben hatte!
zum Haare raufen!

0
@Iamiam

Da fällt mir der Kommentar meinem Bruders ein, der ne Weile an der Hotline PC Hilfe gegeben hat:

"Es reicht nicht den Leuten zu sagen, wohin sie klicken sollen, man muss auch dazu sagen wann sie die Taste wieder loslassen sollen" :-D

Ansonten ist ein Stern sicherlich mal nett, aber im großen an Ganzen ist das Bewertungssystem eher mau.

Wieviele echt blödsinnige Fragen, die mehr DH für die Frage bekommen, als Antworten. Dann sind oft (na gut nicht im Fachgebiet Excel) offensichtlich falsche Antworten mit ettlichen DH bewertet usw.

Und Hand aufs Herz, Wer von uns hat noch keinen Antwort gefunden bei der er gedacht hat "wie zu Teufel kann so eine Knallcharge Gold-/Platinfragant sein??"

Aber ich reg mich nicht auf, für mich ist das hier Hilfe für den der es braucht und man selber rostet nicht ein, bzw lernt noch was. Außerdem hab ich grad seit ner Woche Silber, ich brauche grad keine Sterne ^^

Der lamiam hats auch verdient.

Grüße

Jackie

1

das schaffst du mit dieser Formel

=SUMME((A1:A10<>"")*(B1:B10="Inhalt"))

die du aber nicht wie gewohnt mit enter sondern mit strg+shift+Enter bestätigst

Alternativ wäre eine Lösung mittels Zählewenns denkbar

hier die Zählewenns Version

=ZÄHLENWENNS(A1:A10;"<>"&"";B1:B10;"Inhalt")

2
@Jackie251

obige (sog. Matrix-)Formel nimmt nach der Eingabe mit strg+shift+Enter diese Gestalt an:
{=SUMME((A1:A10<>"")* (B1:B10="Inhalt"))}
Sobald man in die Zelle klickt, verschwinden die geschweiften Klammern und man muss erneut mit strg+shift+Enter eingeben.
Die in meiner AW genannte Summenprodukt-Formel benötigt diese Eingabe nicht, kann aber auch nicht alles, was Matrixformeln sonst so noch schaffen. Für den Zweck hier reichts aber locker!

0
@Iamiam

mir ist summenprodukt immer etwas suspekt wenn es beim syntax Bereiche1 x Bereich 2 funktioniert, aber beim Syntax Bereich1;Bereich2 nicht.

Irgenwie sind ist es die Urzeitlich gelernte Excellogik, das man eben nicht das Rechenzeichen benötigt, wenn man die entsprechende Funktion nutzt :-D

Finde Excel hier einfach inkonsequent. Und an Matrixformel ist ja nix schlimmes.

:-)

0
@Jackie251

@Jackie:
Der Zellvergleich liefert WAHR oder FALSCH, was nicht summiert werden kann.

=SUMMENPRODUKT(Bereich1*1;Bereich2*1)

geht dagegen: durch die Multiplikation wird WAHR zu 1 umgewandelt!

www.online-excel.de/excel/singsel.php?f=26

gibt eine gut verständliche Einführung in Matrixformeln und behandelt auch dieses Phänomen, hab das leider erst NACH meinem Arbeitsleben und angeregt durch hier gelernt, dabei finde ich es gar nicht so schwierig!

Vorstellung: die Matrixformel schafft eine virtuell-virtuelle Spalte oder Zeile mit dem Formel-Ergebnis.
Markiere (bei einer kleinen Auswahl, also nicht A:A) in der Bearbeitungszeile einen in sich geschlossenen Formelteil:
Drücke F9: Du siehst einen Ergebnis-Vektor und beim Markieren eines zweiten den dazugehörigen Ergebnisvektor (weißt Du vllt aber längst)

0
@Iamiam

F9 kannte ich jetzt nicht - DANKE :-D

Das Summenprodukt schlichtweg ein Problem mit "wahr" hat ist mit bewusst. Ich finde es nur absolut unlogisch, dass eine Funktion die direkt dazu da ist multiple Produkte zu berechnen, nicht mehr weiterkommt, wenn es gilt "wahr" * XYZ zu berechnen, während schon die Basismultiplikation =wahr*XYZ zum ergebnis XYZ führt (bzw zu Null bei falsch).

Bei den Einsteigerfunktionen "lern" man, dass man bei der Funktion "summe" gar kein "+" als Rechenzeichnung mehr benötig, genaugenommen, kann Summe mit dem Rechenzeichen gar nichts anfangen. Aber Produktsumme kann die Rechenvorschrift (X*Y) auswerten, währen ist bei der Angabe der gleichen Bereiche nur in syntaxkonformer Form also (X;Y) kopfkratzenderweise nicht versteht was zu tuen ist.

Das empfinde ich einfach als Inkonsequenz in Vollendung :-)

1
@Jackie251

Hab Dein Statement zum Anlass genommen, mich nochmals damit auseinanderzusetzen.
Demo-Beispiel: schreibe in C1:C4 die Zahlen 2;4;3;6
=Summenprodukt(C1 *C2;C3 *C4) => =SUMMENPRODUKT(2 *4;3 *6)
=> =SUMMENPRODUKT(8;18) = (8 * 18)=> 144
Hingegen:
=SUMMENPRODUKT(C1:C2;C3:C4) => =SUMMENPRODUKT({2;4};{3;6})
gleichbedeutend mit
=({2;4} *{3;6}) => 2 *3 + 4 *6 => 30
das entspricht m.Erinnerung nach den Regeln für die Multiplikation von Matritzen bzw Vektoren
(war da nie ganz fit: Hab vor 45 Jahren mal eine Klausur zu "Determinanten und Matritzen" nur mit Ach und Krach bestanden und deshalb das Nebenfach Kristallographie gemieden - da braucht man das nämlich, unter Anderem)

0
@Iamiam

Man muss natürlich vorher klären was man genau machen will, ggf will man ja gar kein Summenprodukt sondern mmult.

In deinem Beispiel sieht den Fehler nicht so gut. Ergänzt man in deinem Beispiel in Spalte d D1:D4 Wahr;Wahr;Falsch;Falsch

=SUMMENPRODUKT(C1:C4;D1:D4)

Für Summenprodukt besagt der Syntax daher C1D1+C2D2+C3... Sollte nun 2Wahr+4wahr+3falsch+6falsch = 2* 1 + 4 * 1 + 3 * 0 + 6 * 0 = 6 rechnen. Es kommt aber zum Ergebniss 0 Wenn hingegen die Arrays direkt Multipliziert werden

=SUMMENPRODUKT(C1:C4*D1:D4)

Dann kommt es auf 6

Selbst wenn man die Spalte mit den wahrheitswerten zunächst normalisiert

=SUMMENPRODUKT(C1:C4;D1:D4*1)

Schafft Summenprodukt das korrekte Ergebnis von 6 zu ermitteln.

Ich könnte Verstehen wenn Summenprodukt direkt 6 liefert, ich könnte nachvollziehen, wenn es einen Fehler meldet, weil es nicht mit Textwerten arbeiten möchte. Was ich nicht nachvollziehen kann, un daher traue ich der Funktion nicht, ist das sang und klanglos einfach 0 herauskommen.

1
@Jackie251

:)
mmult() : eine neue Anregung, mich mal damit zu befassen!

0

Probiers mal mit folgender Formel.

=ZÄHLENWENNS(A1:A10;"";B1:B10;"INHALT")

Was möchtest Du wissen?