Excel 2013, Tabelle1 mit unsortierten Werten in Tabelle 2 nur sortiert?

... komplette Frage anzeigen

2 Antworten

Du kannst, wie Ninombre schreibt, eine Pivottabelle nutzen oder du arbeitest mit Teilergebnissen / Autogliederung.

Als dritte Möglichkeit kannst du die Daten konsolidieren (siehe Screenshot)

Daten → Konsolidieren

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
26.11.2015, 15:35

Das sind auch gute Alternativen 

0

Ich finde das vom Aufbau etwas merkwürdig, wenn in der Spalte neben einer unsortierten auch sortierte stehen.
Wäre eine Tabelle darunter nicht eine Option? Das ließe sich mit einer Pivottabelle sauber lösen.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Ninombre
26.11.2015, 15:23

Ansonsten dieser Ansatz
=WENN(SUMME(WENN(A$1:A$100="";0;1/ZÄHLENWENN(A$1:A$100;A$1:A$100)))<ZEILE();"";INDIREKT("A"&KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN(A$1;;;ZEILE($1:$100));A$1:A$100)=1;ZEILE($1:$100));ZEILE(A1))))

von dieser Seite übernommen:http://www.office-loesung.de/ftopic269294_0_0_asc.php

Das gehört dann in die Spalte C, wenn ich den Aufbau Deiner Tabelle richtig verstanden habe.
Als Matrixformel mit STRG+SHIFT+ENTER abschließen, damit sich um die Formel noch { } bilden.

Wenn die Namen (unsortiert) nicht in Spalte A stehen, muss das angepasst werden.


Spalte D wäre dann: =SUMMEWENN(A$1:A$100;C1;B$1:B$100)


1

Was möchtest Du wissen?