Excel 2013 - wie kann ich die ersten 2 Zahlen einer Zelle durch Formel herausfiltern?

...komplette Frage anzeigen

5 Antworten

hiermit würde das gehen

=TEIL(A6;VERGLEICH(1;ISTZAHL(TEIL(A6;ZEILE(INDIREKT("1:"&LÄNGE(A6)));1)*1)*1;0);2)

ist eine Matrixformel also mit strg + shift + enter abschließen

Antwort bewerten Vielen Dank für Deine Bewertung
ralph2108 25.01.2016, 15:47

Super, perfekte antwort, danke!
die Kitsche darauf wäre, wen man mit einer "WENN(...)" es irgendwie hinbasteln könnte, dass die Zahl nur dasteht, wen eben auch eine Berechnet wird da sonst steht "#NV' was eben nicht so schön ist.

Geht das?

0
Jackie251 25.01.2016, 15:49
@ralph2108

das ginge dann so

=WennNV(TEIL(A6;VERGLEICH(1;ISTZAHL(TEIL(A6;ZEILE(INDIREKT("1:"&LÄNGE(A6)));1)*1)*1;0);2);"")

und wieder mit strg+shift+enter abschließen

0
Iamiam 25.01.2016, 16:10
@Jackie251

WennNV geht bei mir (xl2010) (noch?) nicht, deshalb im alten Stil so:

{  =WENN(ISTNV(TEIL(A1;VERGLEICH(1;ISTZAHL(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)*1;0);2));"";TEIL(A1;VERGLEICH(1;ISTZAHL(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)*1;0);2))  }

ebenfalls Matrixformel. zu Matrixformeln:

www.online - excel.de/excel/singsel.php?f=26

3
Iamiam 25.01.2016, 16:33
@Iamiam

allerdings wird aus xxx1yyy 1y widergegeben, das auszuschließen geht hier ausnahmsweise mal einfach:

{ =WENNFEHLER(WENN(ISTNV(TEIL(A1;VERGLEICH(1;ISTZAHL(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)*1;0);2));"-";TEIL(A1;VERGLEICH(1;ISTZAHL(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1)*1)*1;0);2))*1;"-")  }

1

Probiere einmal folgendes. Ich habe in C1, C2, ... deine Texte eingetragen.

=WENNFEHLER(TEIL(C1;MIN(WENN(WENNFEHLER(ZEILE($1:$999)*(TEIL(C1;ZEILE($1:$999);2)+0>9);0)>0;ZEILE($1:$999)*(TEIL(C1;ZEILE($1:$999);2)+0>9)));2)+0;"")

Das ist eine Matrixformel, deren Eingabe mit Strg + Shift + Enter abgeschlossen werden muss.

Antwort bewerten Vielen Dank für Deine Bewertung

Das geht mit

{=TEIL(A1;VERGLEICH(WAHR;ISTZAHL(TEIL(A1;SPALTE(A1:IQ1);1)*1);0);2)}

(schamlos abgeschrieben und adaptiert von http://excelformeln.de/formeln.html?welcher=101 )

Es handelt sich um eine Matrixformel. Die geschweiften Klammern werden nicht eingegeben, sondern die Formel wird mit Strg+Shift+Enter abgeschlossen. Das erzeugt die {}.

Antwort bewerten Vielen Dank für Deine Bewertung
Iamiam 25.01.2016, 16:57

ist zwar die kürzeste, macht aber Schwierigkeiten beim Kopieren, da muss man sehr genau nachbessern!

0
DeeDee07 25.01.2016, 17:22
@Iamiam

Ich kann die Formel ohne weiteres vertikal kopieren, sie passt sich an. Fürs horizontale Kopieren muss man lediglich SPALTE($A1:$IQ1) verwenden, also Spalten fixieren.

0

Wenn immer ein Leerzeichen zwischen Word und den Zahlen steht, ginge es so:
=TEIL(A1;FINDEN(" ";A1)+1;2)

Das Leerzeichen finden und ab diese Stelle 2 Zeichen übernehmen.


Antwort bewerten Vielen Dank für Deine Bewertung
Jackie251 25.01.2016, 13:59

wollte ich auch schon, das geht aber nicht, da die anzahl der Leerzeichen variiert
siehe "Sun Odyssey 509" => soll 50 Liefern

man braucht schon etwas das alles was keine Ziffer ist wegfiltert

1
Ninombre 25.01.2016, 14:20
@Jackie251

Das Beispiel hatte ich übersehen, gute Anmerkung, da bringt das Leerzeichen natürlich keine Lösung

0

=LINKS(VERWEIS(9^9;1*RECHTS(A1;SPALTE(A1:IQ1)));2)

Antwort bewerten Vielen Dank für Deine Bewertung
Jackie251 25.01.2016, 16:20

Hat streng genommen ein paar Bedingungen, zb wie groß die Zahl werden darf, und das die auszuwertende Zelle muss auf der gesuchten Zahl enden

Aber sonst kurz und ohne Matrix, ich finde es eine sehr gute Lösung!

0
dkilli 25.01.2016, 18:17
@Jackie251

abcd efg hijk AbcdefG 123456789 

Das habe ich in A1 eingegeben. Es funktioniert. Größere Zahlen würde Excel überfordern. 

Ich bin auch davon ausgegangen, dass hinter der Zahl keine Buchstaben kommen. 

Aber trotzdem Danke für deinen Kommentar. 

0

Was möchtest Du wissen?