Excel 2010, wie eine Formel inkrementieren?

2 Antworten

Ok, wenn ich das jetzt richtig verstanden habe mach mal folgende Formel in folgende Zellen:

Für die erste Berechnung nimm mal in z.b. E1:

=(INDEX(A:A;(ZEILE(A1)-1)*50+50)-INDEX(A:A;(ZEILE(A1)-1)*49+1))/(INDEX(D:D;(ZEILE(D1)-1)*50+50)-INDEX(D:D;(ZEILE(D1)-1)*49+1))

und auf E2 runterziehen.

Ab der dritten Berechnung kannst du in der Formel nicht mehr mit 49+1 rechnen, sondern dieser Teil muss dann in 50+0 geändert werden. Also kommt in Zelle E3 folgende Formel:

=(INDEX(A:A;(ZEILE(A3)-1)*50+50)-INDEX(A:A;(ZEILE(A3)-1)*50+0))/(INDEX(D:D;(ZEILE(D3)-1)*50+50)-INDEX(D:D;(ZEILE(D3)-1)*50+0))

Diese kannst du dann bis dahin wo du sie brauchst runterziehen.

Erklärung:

Da deine Berechnung bei Zeile 1 beginnt und du aber Zeile 50 in die Berechnung einbeziehst, darfst du die ersten beiden Berechnungen nur +49 Zeilen machen und dann ab der dritten Berechnung weiter in +50 Zeilen schritten.

Kannst du damit was anfangen?

2

Danke, das bringt mich schon ein ganzes Stück weiter!

0
53
@chelioschev

Wenn es so klappt, dann ist alles ok.
Aber denke vlt. nochmal darüber nach, ob Du nicht doch:

Zelle 1 : =(A50-A1)/(D50-D1)
Zelle 2 : =(A100-A51)/(D100-D51)
Zelle 3 : =(A150-A101)/(D150-D101)
usw.
berechnen willst. Das wäre logischer, denn:
50+ 50= 100
1  + 50 = 51

0
25
@Oubyi

Ich verstehe deine bedenken, laut Frage will er aber eigentlich immer die Zeile +50 haben. Kann aber leider weil die erste Zeile ja mit zählt nicht gleich mit der richtigen Formel starten. Deswegen die zwei verschiedenen. Oder habe ich da was falsch verstanden?

0
53
@schmiddi1967

Klar, die Frage war so gestellt, wie Du es verstanden hast, ich wollte nur zu Bedenken geben, ob der Ansatz nicht schon fehlerhaft ist.
Aber wahrscheinlich werden wir das wohl nicht mehr erfahren, da der FS sich offensichtlich - wie leider so oft - nicht mehr für die Antworten interessiert.

0
25
@Oubyi

Ja, oder sie haben die passende Antwort bekommen und melden sich einfach nicht mehr. Schade eigentlich :((

1

was verstehst du denn unter inkrementieren?

Soll die erste Zeile in der Klammer jeweils im 50 erhöht und die zweite jeweils um 49 erhöhrt werden?

25

Ich glaube er will das fast so haben, nur das 49er Schritte alleine da nicht helfen werden. Spätestens ab der dritten Berechnung geht das in die Hose :))

0
53
@schmiddi1967

Wir könnten ja einen kleinen Flamewar beginnen über 1-basierte versus 0-basierte Arrays in Objekten, die für Laien sichtbar sind (wie Excel-Tabellen).

0

Excel: ZÄHLENWENN mit Teilstrings und Variable?

Hey,

folgendes würde ich gerne realisieren:

in der Spalte A soll nach Begriffen gesucht werden, welche in Sätzen vorkommen und die Anzahl gezählt werden. Dabei soll allerdings auch gezählt werden, falls das Wort in einem anderen Wort enthalten ist (bsp: Baum, Kastanienbaum) Außerdem soll das ganze nicht statisch sein, sondern eine Variable enthalten.

Beispiel:

Ich möchte die Anzahl des Wortes "Baum" in den Zellen A1:A100 (pro Zelle Anzahl Baum <= 1)

Das ganze sieht bis lang so aus:

=ZÄHLENWENN(A1:A100;B1)

B1 ist hier die Variable.

In diesem Fall wäre das "* baum *". (ohne die Lehrzeichen zwischen den "", allerdings meint gf.net es müsse die * als Aufruf zum kursivschreiben betrachten ... <.<)

Jetzt die eigentliche Frage:

Ist es möglich die Formel so zu ändern, dass ich statt "* wort " lediglich "wort" in die Zelle B1 schreiben muss, ohne das dadurch der Aspekt mit den Teilstring verloren geht <.<

Das ganze soll dann in etwa so aussehen (was natürlich nicht funktionier, da ein Zellenbezug zwischen zwei " kein Zellenbezug mehr ist ^_^)

=ZÄHLENWENN(A1:A100;"* Zellenbezug *")

bzw:

=ZÄHLENWENN(A1:A100;* Zellenbezug *)

Lg Tobi

...zur Frage

Was möchtest Du wissen?