Excel 2010 Stunden addieren die >24 ergeben

 - (Zeit, Excel, Tabellenkalkulation)

4 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

Ha, das ist aber mal kniffelig gewesen. Die Lösung liegt in dem Berechnen der einzelnen Stunden. Bei Excel ist das Zeitformat immer so, dass 24 Std Zeitformat = 1 im Dezimalformat ist, es wird also intern immer in Tagen bzw. Komma-Tagen gerechnet. Wenn du bei deiner Abfrage diese Wenn-Prüfung machst, musst du anstatt der 24 (die so 24 Tage sind) eine 1 (=24Std) eintragen. Dann passt es mit dem Format [h]:mm

Oh man... klasse.. es funktioniert... da wäre ich nie drauf gekommen... :D

Vielen Dank :D

0

Ich habe mich jetzt nicht weiter in Dein "Formelwerk" vertieft.
Aber wenn ich mir Deinen Screenshot ansehe, denke ich, dass Du das zu kompliziert anfasst.
Ich würde es so machen:
Formatiere die komplette Spalte Z als:
[hh]:mm
Schreibe dann in X1 die Formel:

=REST(Z1-Y1;1)

und kopiere sie runter.
Zum Schluss dann halt:
=REST(Z1-Y1;1)
und fertig.
ODER?

Woher ich das weiß:Beruf – IT-Administrator (i.R.)

Sorry, Kopierfehler.
Zum Schluss dann halt:
=SUMME(X1:X24)
natürlich.

0

Die Restformel funktioniert nur bei Tagesschichten. Bei Schichten wo der Beginnwert höher ist als der Endwert funktioiert, dass nicht. Deswegen musste ich die WENN-Funktion anwenden... Was aber auch wunderbar funktioniert... Aber des Rätselslösung hat schon "maussuam" schon geliefert... Ich hatte einen Fehler in der Formatierung =WENN(Y2>Z2;24-Y2+Z2;Z2-Y2)

Anstatt 24 (für Std) muss dort 1 (für Tag), das wusste ich nicht... Seitdem läuft es perfekt....

Aber trotzdem vielen Dank... :)

0
@FrageAntwortix

"Die Restformel funktioniert nur bei Tagesschichten. Bei Schichten wo der Beginnwert höher ist als der Endwert funktioiert, dass nicht."
Das stimmt nicht!!!
Gerade DAFÜR ist diese Formel notwendig, sonst würde Z1-Y1 reichen.

Aber wenn Du Dein Problem komplizierter gelöst hast, ist das auch ok, Hauptsache es klappt.

0

=WENN(B1>A1;(B1-A1)24;24+((B1-A1)24))

nutze bitte diese Formel das Ergebnis ist dezimal und kann für weitere Berechnungen genutzt werden

Zelle wo das Ergebnis erscheinen soll folgend benutzerdefiniert Formatieren: [h]:mm;@

hab ich ja schon gemacht, aber ich bekomme da einen absolut falschen Wert... Ich denke, dass liegt an der Formel =WENN(Y2>Z2;24-Y2+Z2;Z2-Y2) usw. die ich in den orangen Felder (Gesamt,X2-X32) installiert habe... Ich hab das Format von Uhrzeit zu...[h]:mm mal testweise auf die oranagen Felder (Gesamt,X2-X32) umgestellt und dabei festgestellt, dass immer die Zeiten die die 0:00h Grenze überschritten hatten... einen Wert von über 500 aufwiesen, die eigentlich nie grösser als 24 (h) sein dürften... Bei Zeiten (z.B, Frühschicht) da rechnet Excel den korrekten Wert... Bei Nachtschichten bekomm ich einen falschen Wert...

0

Was möchtest Du wissen?