Excel 2010 - Daten vergleichen

...komplette Frage anzeigen

1 Antwort

Auf die Schnelle aus dem Kopf:

=ZÄHLENWENN(A:A; SÄUBERN(C1)) in B1 und runterziehen.

DoranB 12.02.2015, 16:29

Vielen Dank. Funktioniert leider auch nicht. Wenn ich den Abstand entferne, funktioniert die Formel. Jedoch eben mit Leerzeichen nicht ;(

0
DoranB 12.02.2015, 16:44
@Ifm001

Hat funktioniert! Herzlichen Dank!

0
Iamiam 12.02.2015, 23:08
@DoranB

mit =Vergleich(A1&"*";C:C;0)
kriegst Du auch gleich noch -wenn vorhanden,- die Zeile geliefert, wenn nicht, Fehler.

=Wennfehler(=Vergleich(A1&"*";C:C;0);"nicht gefunden")
unterdrückt auch den. (erst ab xl2007 oder auch noch letzte Updates von 2003?)

0
Ifm001 12.02.2015, 16:53

Ich sehe gerade, dass ja die zu durch suchend Spalte C ist. Dann kann man sich eine Hilfsspalte für die "bereinigte" Bezeichnung erzeugen:

=SÄUBERN(C1) in D1 und runterziehen =ZÄHLENWENN(D:D; A1) in B1 und runterziehen.

Zudem prüfen, ob die Leerzeichen wirklich Leerzeichen sind ... z. B. mit =CODE(RECHTS(C1; 1). Beim Leerzeichen sollte da 32 stehen.

0
Ifm001 12.02.2015, 17:02

Auch wenn Du dein Problem schon gelöst hast ... es geht noch einfacher:

=ZÄHLENWENN(C:C; A1 & "*")) in B1 und runterziehen.

1

Was möchtest Du wissen?