Excel 07 "Wenn"-Formel mit 2 Bedingungen?

...komplette Frage anzeigen

3 Antworten

=WENN(A2="samstag";1;WENN(A2="sonntag";1;0))
Ist jetzt einfach andersrum: Samstag und Sonntag gibt 1, alles andere 0

Joey72 04.10.2010, 20:37

danke! Jetzt hat's funktioniert! Scheinbar hatte ich zu viele Anführungszeichen, dass es Excel nicht gefiel und immer Fehlermeldung brachte...

0

MacSwitchers Formel klappt natürlich.
Aber es geht auch mit pocetnicks boolscher Algebra. Und eigentlich sogar etwas sinnvoller/ eleganter:
=WENN(ODER(A3="Samstag";A3="Sonntag");1;0)
Ist dann auch ausbaufähiger.

Kenn mich jetzt nicht mit Excell aus, aber um sowas zu prüfen benutzt man boolsche Algebra.

Also AND, OR, NOR usw...

Joey72 04.10.2010, 20:38

Danke für deine Antwort, aber das hat mir leider gar nix gebracht, sorry...

0

Was möchtest Du wissen?