Excel -Wie kann ich Werte einer anderen Spalte unter eine bestimmten Bedingung nutzen?

...komplette Frage anzeigen

4 Antworten

das kannst du hiermit machen

=SUMME((B3:B8>C3:C8)*B3:B8)+SUMME(C3:C8)

ist aber eine Arrayformel, d.h. du musst die zelle nicht mit enter sondern mit shift+strg+enter abschließen

Schloni1995 26.11.2015, 21:16

Okay danke, du hast mir wirklich geholfen! Ich hab noch nie von einer Arrayformel gehört. Aber es geht, so einfach:D

0

Hei, also deine Formel ergibt leider keinen Sinn,

Frimeln wir die mal etwas auseinander:

Wir haben eine WENN Funktion Verknüpft mit ODER

=WENN(C3 ODER(C4;C5;C6 ;C7;C8)=0....

Besser wäre diese Formel aber (finde ich) so:

=WENN(ODER(C3;C4;C5;C6 ;C7;C8)=0....

Dieser Teil der WENN Funktion ist die Überprüfung,

Das Semikolon nach =0

ODER(C4;C5;C6 ;C7;C8)= 0;<- Das hier

Lässt ruft den 2. Parameter der WENN Funktion auf, warum du da eine Klammer machst:...

=WENN(C3 ODER(C4;C5;C6 ;C7;C8)= 0;( <- ?!? o.O

...keine Ahnung, ... jedenfalls sind wir dann im DANN Bereich der Wenn Funktion!

Dein DANN Bereich sagt hier nur aus mache gleich 0, wobei das hier nicht mal die Zahl 0 ist sondern ein einfacher WAHR oder FALSCH Aufruf, wenn du die Zahl 0 schreiben wölltest, solltest du diese 0 in Anführungszeichen setzen:

Nochmal die Formel:

 =WENN([PRÜFUNG(C3 ODER(C4;C5;C6[Warum ist hier ein Leerzeichen?!? o.O];C7;C8)= 0];DANN[(0];SONST[SUMME(B3:B8)];KEINEAHNUN?oO?!?[SUMME(C3:C8))] 

Also, die Formel ist zu viel und/oder unvollständig.
Richtig wäre es in meinen Augen so, jedoch trotzdem unvollständig und falsch!

Also, das was DU hier versuchst mit dieser Formel sollte so geschrieben werden, funktioniert aber Trotzdem nicht;

 =WENN(ODER(C3MC4;C5;C6;C7;C8)="0";"0";SUMME(B3:B8)[;SUMME(C3:C8))] <- Dieser Teil ist zu viel oder es fehlt was, was willst du damit erreichen? 

Vielleicht konnte ich dir etwas helfen!

Grüße,


iMPerFekTioN

Schloni1995 26.11.2015, 21:14

Danke deine Syntaxtipps haben erstmal geholfen. Ich Doofi war auch noch nicht fertig mit der Formel. Mein Ziel steht oben in der Fragebeschreibung.

0

Schau dir mal die Funktionen

SUMMEWENN

und

SUMMEWENNS

näher an.

Alternativ zum Basteln von Formen wäre eine schnelle Lösung, wenn Du einfach bei den Geschenken mit festen Wert diesen nicht nur bei Minimal, sondern auch bei Maximal einträgst. Im Grunde ist ja der Minimal und Maximalbetrag bekannt, wenn der Preis feststeht. Dann sparst Du komplizierte Formeln und kannst einfach die Summe über die beiden Spalten bilden.

Was möchtest Du wissen?