Excel -wenn/dann/formel-

3 Antworten

Vom Fragesteller als hilfreich ausgezeichnet

=wenn(A1=OR("Urlaub";"WAZ";"Krank";"Feiertag");"08:00";G1-F1-H1)

Bei dem H1-Problem hat der Kollege recht...aber möglicherweise hast du nur einen Fehler in der Zellbezeichnung.

Die Anführungszeichen bei "08:00" könnten evt. ein Problem werden, weil damit idR. Text erzwungen wird. Ggf. weglassen und ausprobieren. Die Zelle sollte auf jeden Fall als Uhrzeit formatiert werden - es sei denn, dass du nicht damit rechnen willst. Dann kann es auch als Text drinbleiben.

so gehts nicht, die Formel müsste heissen: =WENN(ODER(A1="Urlaub";A1="WAZ";A1="Krank";A1="Feiertag");"08:00";G1-F1-H1)

aber siehe dazu AW von Suboptimierer!

und pass auf, dass keine negativen Zeiten entstehen können, da ist XL SEHR ALLGERISCH!

2

Kann es sein das du dich da irgendwo vertan hast?

Eigentlich hat wenn so eine Bezeichnung auftaucht da nicht eine Uhrzeit sondern eine Stundenanzahl was zu suchen. Ich gehe mal davon aus das du mit deiner Formel Ende-Beginn-Pause aussagen willst, also sollte doch eigentlich bei Krank und so auch nur die Stundenanzahl angezeigt werden weil man da ja nicht Arbeitet oder?

Wie gesagt wenn du das wirklich so meinst würde ich dir raten da nicht wie du das eventuell tatsächlich vor hast da Beginn und Ende einzutragen sondern nur die Stundenanzahl, weil sonst ist es nicht möglich wie das Suboptimierer schon geschrieben hat.

Aber natürlich nicht beides in H1 sondern die gearbeiteten Stunden extra.

Das geht nicht. Du bekommst im Sonstzweig einen Zirkelbezug. Du kannst in H1 keine Formel definieren, die auf sich selbst rückbezieht.

(ohne Aktivierung der iterativen Berechnungsoption)

Was möchtest Du wissen?