Excel / VBA Programmieren: Felder in anderer Tabelle automatisch beschreiben

...komplette Frage anzeigen

4 Antworten

In Excel kannst du das mit der SUMMEWENNS-Funktion erledigen, etwa so:

=SUMMEWENNS(D:D;A:A;"November";C:C;"Rubik X")

Diese Formel summiert alle Zahlen aus Spalte D, in deren Zeilen sowohl "November" in A als auch "Rubik X" in C steht. Statt der Kriterien als Zeichenketten kannst du auch Bezüge (Zellen) verwenden. Da die ganze Spalte ausgewählt wird, werden auch alle (Neu)Einträge berücksichtigt.

Sollte in A nicht der Monatsname, sondern ein Datum stehen, kannst du die Summenprodukt-Funktion verwenden:

=SUMMENPRODUKT((MONAT(A:A)=11)*(C:C="Rubik X")*(D:D))

sollte das gleiche Ergebnis liefern.
Wenn man bei Summenprodukt die ganze Spalte auswählt, kann es zu Performance-Problemen kommen, vielleicht ist eine Einschränkung sinnvoll (A1:A1000 statt A:A usw.)

Inwieweit das mit Numbers umsetzbar ist, weiß ich nicht.

Übrigens war nicht Keynote sondern Numbers (Apple) gemeint.

Die Zeilen sind auch mit einem Timestamp versehen Praktisch soll also ein Programm die ganze Spalte der Rubriken durchgehen und dann beispielsweise bei folgender Zeile:

1 | November | Transaktion 1| Rubrik X | 100

in dem Tabellenblatt November Rubrik X um 100 erhöht werden. Das ganze dann aber auch für viele (200+) Zeilen

VG, Ben

Zwischen Excel und Numbers bestehen schon große Unterschiede.

Zunächst sind beide einfach nur Tabellenkalkulationen, die dazu da sind, auf die schnelle ein paar Ergebnisse zu produzieren. Nicht mehr und nicht weniger.

Wenn Microsoft glaubt, sein Produkt zu einer eierlegenden Wollmilchsauziege zu machen, ist das die Entscheidung von Microsoft.

Apple geht hier seine eigenen Wege und das ist gut so.

Die Funktionen, die du deinen Kalkulationen angedeihen lassen willst, könnte man eleganter in Datenbanken lösen! Dort ist man dann nicht so von einzelnen Blättern abhängig!

angenommen, eingabe ist erste tabelle, vierte spalte, zweite reihe - summe ist zweite tabelle, zweite spalte, zweite reihe

über entwicklertools kannst du in der ersten tabelle eine funktion einfügen, in diesem fall ein ereignis, eine änderung

zuerst wird abgefragt, ob die änderung die eingabezelle betrifft und danach zur summenzelle addiert


Private Sub Worksheet_SelectionChange(ByVal Target As Range)

If Target.Address = "$D$3" Then

Worksheets(2).Cells(2, 2) = Worksheets(2).Cells(2, 2) + Worksheets(1).Cells(2, 4)

End If

End Sub

Was möchtest Du wissen?