Excel - wie kann ich die ANzahl der Tage eines Monats berechnen?

... komplette Frage anzeigen

4 Antworten

Hallo,

das ist mir etwas zu dünn.

Inwiefern hat das Eintrittdatum oder das Austrittdatum etwas mit den Anwesenheitstagen des aktuellen Monats zu tun? Klar, wenn Eintritt oder Austritt in den Monat fallen, aber sonst?

Grundsätzlich gibt es für die Berechnung der Differenz 2er Daten die Möglichkeit mit DATEDIF zu agieren oder einfach =heute()-A1... je nachdem mit entsprechenden Bedingungen ergänzt.

Wenn du mehr Infos bringst, kann man auch mehr Hilfe geben. Am besten wäre, du lädst einen Screenshot hoch.

LG, Chris

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn A die Austritts- und E die EintrittsSpalte ist, dann

  • =((A1="")*(Tag(Heute()+1))+(A1<>"")*Tag(A1)-Max(0;(Monat(E1)=Monat(A1))*Tag(E1)))

Verschieb die Spalten entsprechend Deinen Gegebenheiten, die Formel passt sich ja an, Du hast leider keine Orte angegeben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
04.07.2017, 13:33

Da war wohl noch ein Fehler drin. So sollte es stimmen:

  • =(A1="")*TAG(HEUTE())+(A1<>"")*(TAG(A1))-MAX(1;(MONAT(E1)=MONAT(A1))*TAG(E1))+1

Kann auch als =Wenn(A1="";Tag(heute();Tag(A1))-Max(1;...  formuliert werden

0

Ist vielleicht ein bisschen umständlich, sollte aber klappen:

=WENN(MONAT(B1)=MONAT(HEUTE());TAG(B1)-WENN(MONAT(A1)=MONAT(HEUTE());TAG(A1);0);0)

Voraussetzung ist Eintrittsdatum in A1 ist vor dem Austrittsdatum in B1.
Habe ich Dich richtig verstanden?
Teste mal genau?
Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung

Eintrittsdatum stehe in A1

= TAG(HEUTE()) - TAG(A1)

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?