Excel - Werte in mehreren Spalten suchen, vergleichen und weiteren Wert wiedergeben

Tabellen - (Excel, Sverweis)

3 Antworten

Diese Formel in C3 sollte das imho lösen: 

{=INDEX($D$3:$D$10;VERGLEICH(F3&G3&H3;$A$3:$A$10&$B$3:$B$10&$C$3:$C$10;0))} 

**ACHTUNG!**  

Das ist eine Matrixformel. Das bedeutet: Die geschweiften Klammern {} NICHT mit eingeben, sondern die Eingabe der Formel NICHT mit ENTER abschließen, sondern mit: STRG & SHIFT & ENTER (alle drei gleichzeitig). DAS erzeugt die { } und macht die Formel zu einer Matrixformel.

Wenn Du ganz sicher gehen willst, dann ergänze die Formel noch so:  

{=INDEX($D$3:$D$10;VERGLEICH(F3&"#"&G3&"#"&H3;$A$3:$A$10&"#"&$B$3:$B$10&"#"&$C$3:$C$10;0))}

Kommst Du klar? 

1

Juhuuu. Es hat geklappt! Vielen Dank!

Ich hätte noch eine Verständnisfrage:

Warum muss ich vor und nach dem & das "#" schreiben?

Viele Grüße

1
53
@schnurzpiep

Es kommt darauf an, was für Werte genau in den Zelle stehen. 

In der kürzeren Formel reihe ich die Werte ja einfach aneinander und suche dann danach.

Aber mal angenommen ich habe die Werte: 12, 5, 17. Dann wird daraus 12517. Wenn im Suchbereich jetzt: 1, 25, 17 steht, dann wird daraus auch 12517 und es gibt einen falschen Treffer.

Mit den Trennzeichen (das muss nich # sein, nur etwas das im Wertebereich nicht vorkommen darf) wir daraus 12#5#17 und 1#25#17 und es kommt zu keinem falschen Treffer. 

Ist das so verständlich? 

0

Davon ausgehend, dass die Reihenfolge der Werte in beiden Spalten identisch sein soll, probier mal in I3 folgende Formel:

=WENN((A3*100)+(B3*10)+C3=(F3*100)+(G3*10)+H3;D3;"")

Gruß aus Berlin

Kopier alles und füge es ein. ..

Excel Funktion SVerweis funktioniert nicht. Was ist der Fehler?

In einer Arbeitsmappe befinden sich zwei Tabellen(blätter) die beide in der Spalte A die gleichen IDs haben. leider ist es nicht so wirklich eine ID (liegt an der Urquelle), denn in meiner Tabelle 1 sind die IDs mehrfach vorhanden und es gibt welche mit führender Null, weshalb ich sie nicht als Zahl formatieren kann. Ich habe also bspw. die IDs 015 und 15.

In meiner Tabelle 2 kommt jede ID nur einmal vor.

Nun zum Ziel: In Tabelle 1 möchte ich in Spalte B (bisher leer) jeweils einen Wert aus Tabelle 2 in abhängigkeit der ID einfügen: Beispiel:

In Zeile 78 steht in A78 die ID 15 und in B78 soll nun der Wert aus Spalte 5 in der Zeile wo der Wert 15 in Spalte A gefunden wurde.

Meine Funktion sieht so aus: =SVERWEIS(A252;Mengengeruest!A2:A1782;5;falsch)

In dem Dialogfeld "Funktionsargumente" stehen hinter den Angaben die richtigen Werte, aber es gibt kein Ergebnis bzw. in der Tabelle wird #NV ausgegeben.

ich habe mehrere Hilfeseiten studiert, in allen wird das Vorgehen so angegeben wie ich es gemacht habe. Zumindest glaube ich das ;-) Aber irgendwo muss ein Fehler sein.

Kann es am Format der jeweiligen Spalte A (IDs) liegen?

Freue mich über jeden Tipp. Vielen Dank.

...zur Frage

Wert aus Tabelle 1 mehreren Zeilen in Tabelle 2 zuordnen

Ich habe 2 Tabellen. In der ersten Tabelle ist pro Zeile ein Hauptartikel mit einer eindeutigen Artikelnummer aufgeführt. In einer weiteren Spalte der jeweiligen Zeile steht die Katalogseite, in der der Hauptartikel abgebildet ist. Die zweite Tabelle hat alle Varianten eines Hauptartikels. Das sind bis zu 50 Zeilen pro Hauptartikel. Jede Variante hat auch in einer Spalte die Hauptartikelnummer, somit besteht ein eindeutiger Idex zwischen den beiden Tabellen. Jedoch fehlt in der Variantentabelle die Spalte Katalogseite. Wie kann ich die Variantentabelle mit der Katalogseiten des jeweiligen Hauptartikels füllen? Nur zur Verdeutlichung: Tabelle 1, mit einem Hauptartikel pro Zeile hat 650 Zeilen. Tabelle 2 Variantenartikeln, hat 22.000 Zeilen aber auch nur 650 Hauptartikel!

...zur Frage

Was möchtest Du wissen?