Excel - "wenn" addition in andere Zelle?

... komplette Frage anzeigen

2 Antworten

Die Formel kann immer nur auf die Zelle einwirken, in der sie steht. Die Logik müsste also immer sein, das Du in A3 die Formel setzt. Du kannst auch nicht auf den bestehenden Wert von A3 zurückgreifen und die Zelle ändern: Das geht nur über Makros, dass man den Wert von A3 ausliest und dann Zahlen darauf addiert.

Für das konkrete Beispiel könntest Du in A3 schreiben:
=SUMMENPRODUKT((A1:C1>A2:C2)*2)

Es wird also jeweils geprüft, wie oft die Bedingung erfüllt ist und das Ergebnis mit 2 multipliziert.

Das berechnet aber dann direkt den (finalen) Wert für A3, es wird nicht in Zwischenschritten gerechnet, das geht wie gesagt nicht. Als Workaround müsstest Du dann in A4 bspw. weiterrechnen.

Antwort bewerten Vielen Dank für Deine Bewertung

Du kannst für A3 nicht zwei verschiedene Werte haben: A3 KANN nicht gleichzeitig "A3" und "A3+2", "A3+4" oder "A3+6" sein! Entweder, du setzt einen festen Ausgangswert ein (in meinem Beispiel "E1" oder auch 0, 1, 2, 3 usw.) oder du machst die Additionen in einer anderen Zelle (z.B "A4" und benutzt dann statt "E1" eben "A3"

(A3) = E1+WENN(A1>A2;2;0)+WENN(B1>B2;2;0)+WENN(C1>C2;2;0) oder

(A4) = A3+WENN(A1>A2;2;0)+WENN(B1>B2;2;0)+WENN(C1>C2;2;0)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Gipfelstuermer
09.12.2015, 21:27

Doch das geht schon, nur die Formel wird Mega lang. Schreibe das später wenn ich am PC bin. 


Da ist das oben genannte Summenprodukt um ein Vielfaches Komfortabler und deutlich einfacher erweiterbar, dafür etwas startet was die Variante angeht wenn nicht immer +2 gerechnet werden soll sondern verschiedene Werte. 

0

Was möchtest Du wissen?