Excel - Selektive fortlaufende Nummerierung

...komplette Frage anzeigen

3 Antworten

Danke! Habe es mit einer Kombination eurer Antworten hinbekommen. Ich habe das $ Zeichen eingefügt damit der Auswahlbereich konstant bleibt und die Nummerierung rechts mit einer Hilfszeile gemacht, weil sie sowieso schon Teil der Mappe war. Vielen Dank für die shcnelle Hilfe!

Ändere die Formel in Zeile 1 wie folgt und ziehe sie herunter:

=ZÄHLENWENN(F$13:F$80;ZEILE()-1) 

Was aber nur geht, wenn die Formel wirklich in Zeile 1 beginnt und auch dort bleibt.

0
@Schnulli00

Solange der Fragesteller nichts Gegenteiliges schreibt, gehe ich davon aus.

Der Bereich F... der Formel ist auch nur solange gültig, wie er den Bereich nicht ändert. Und wenn der Fragesteller nicht ZÄHLENWENN, sondern SUMMEWENN benötigte, so müsste er auch das ändern.

0
@Schnulli00

PS: Um deiner Anforderung zu genügen, wäre folgende Abwandlung vielleicht die bessere Lösung:

=ZÄHLENWENN(F$13:F$80;ZEILE(A1)-1)
1
@Schnulli00
Was aber nur geht, wenn die Formel wirklich in Zeile 1 beginnt und auch dort bleibt.

Das kann man so umgehen:

=ZÄHLENWENN(F$13:F$80;ZEILE(A1)-1))

1
@Suboptimierer

Gerade hier im Forum würde ich das nicht vorraussetzen, da meist nur rudimentäre Beispiele gegeben werden.

Ich hab mir angewöhnt, auch in meinen Dateien, ZEILE oder SPALTE nie ohne Bezug zu verwenden. Da reicht es wenn du später obendrüber ne Zeile einfügen musst, weil dir noch was einfällt. ZEILE(A1) wird verschoben, ZEILE() musst du jedesmal neu anpassen. Und Dateien wachsen ja meist im Laufe der Zeit.

0
@augsburgchris

Die bessere Variante war mir später erst eingefallen.
Zunächst wollte ich überhaupt eine Lösung bieten und diese war bezogen auf die Fragestellung 100%ig korrekt.

Wenn der Fragesteller eine Zeile einfügt und es dann nicht mehr funktioniert, wird er gezwungen sein, selber sich gewisse Dinge anzugewöhnen. Learning by doing.

0

Nur mit Hilfe einer Hilfsspalte (z.B. Spalte A). Diese enthält von oben nach unten die Zahlen 0,1,2,usw im jeweiligen Feld. Das lässt sich ja schnell nach unten ziehen. In der Formel, die nun zum Beispiel erstmal in B1 stünde, muss dann rein =ZÄHLENWENN(F13:F80;A1) Das kannst du nun nach unten ziehen.

Nur mit Hilfe einer Hilfsspalte

leider falsch.

0

Was möchtest Du wissen?