Excel - Multiplikation - Entweder oder oder?

2 Antworten

Hallo,

ist nur für Insider nachvollziehbar (also für Dich). Unverständlich die Logik und Zuordnung des Fragebeispiels und dem gewollten Ergebnis (Logik).

So wie ich es Deute, würden Zirkelbezüge entstehen, bzw. sind in Spalte B bereits Formeln vorhanden.

Eine detaillierte Abbildung wäre hilfreich !

Du musst nicht unbedingt eine Abbildung der Originaldatei hochladen, aber dennoch ein Datenbeispiel.

Ein bisschen Mühe sollte man sich bei der Fragestellung schon machen, denn bei der Beantwortung von Fragen ist man manchmal sehr lange damit beschäftigt die passende Lösung zu finden.

Gruß Tron

Ist nicht verständlich.

Mach doch einfach =A1 * B1

oder A2 * B2

kannst ja runter ziehen. Wofür das wenn?

Naja wenn: 
ich habe eine der Zahlen die oben in A eingetragen werden müssen als Gegebenheit, die anderen beiden Zahlen sind ein Vielfaches der einen "gegebenen".
welche ich von denen aber habe ist immer unterschiedlich.

Also ergeben sich zb aus einer zahl in:
A1 die Zahlen in B2 und B3
A2 die Zahlen in B1 und B3
A3 die Zahlen in B2 und B1


Ansich brauche ich auch keine wie jetzt hoffentlich ersichtlich 3 mal A und 3 mal B sondern nur ein mal drei Felder, aus denen sich selber das vielfache des anderen ggf gegebenen ergeben.

Denke aber es ist leichter mit sechs Feldern oder? 
Nun verständlicher?


Gruß


0
@BrauchJzHilfe

sry, verstehe ich nicht, gib mir mal bitte die formel.

also ich habe zb folgende mal probiert (nicht lachen bitte)

=WENN(M11="";M11;ODER(N11="";N11*5;O11*1,25))
oder besser
=wenn (wenn (E15="";C15=E15*5;0) ; C15=G15*1,25;0)

0
@pblack493

bzw diese müsste meiner Suche ziemlich nah kommen

=wenn(A1="";A1;wenn(A2="";A2*5;A3*1,25))

0
@BrauchJzHilfe

würde ungern isos oder rars ziehen. kannst du die formel einfach bitte hier mit c+p einfügen?

0
@pblack493

Lad dir einfach die Excel-Datei runter. Sie heißt Mappe1.xlsx, also.

Einfach öffnen und schauen, ob du das meinst. Ich glaube ich habs nämlich noch nicht ganz verstanden

0
@pblack493

Wenn du also in A1 NICHTS hast dann soll er die Werte (also nichts) aus A1 nehmen SONST Soll er A2 *5     ;A3*1,25 ERGIBT EINEN FEHLER IN DER FORMEL

0
@jetzertle

Wenn in A1 nichts is, soll er das nehmen? Wenn was drin steht, soll man A2 nehmen? Wo macht das Sinn?

0
@jetzertle

nee, okay wir kommen dem problem näher, 

-wenn in a1 nichts ist, soll er es nicht nehmen,
-dann soll er b1 nehmen sofern etwas vorhanden ist,
-wenn auch hier nichts ist soll er c1 nehmen.

hab die formel jetzt nochmal umgeschrieben, in die waagerechte, vllt besser zu verstehen

=WENN(A1="";A1;WENN(B1="";B1*5;C1*1,25))

die ist die Formel für im neuen Fall B1

0
@BrauchJzHilfe

Also bei NIX in A1 kommt immer 0, da er den Rest erst betrachtet wenn etwas drin steht. Was soll dieser Schwachsinn

0
@pblack493


-wenn in a1 nichts ist, soll er es nicht nehmen,
=WENN (A1 ="";"";.......

Dann Bleibt B1 LEER WENN IN A1 nix steht


-dann soll er b1 nehmen sofern etwas vorhanden ist,
wenn auch hier nichts ist soll er c1 nehmen.



=WENN (A1 ="";"";WENN(B1="";"";C1)


=WENN (A1 ="";A1;WENN(B1="";B1;C1)





1
@jetzertle

ODER

=WENN(A1>0;A1*1,25;WENN(A2>0;A2*2;A3*5))

Wenn A1 Größer 0 ist dann A1*1,25 SONST

Wenn A2 Größer 0 ist dann A2*2 SONST

 A3 * 5

Wenn A1 NIX ist guckt er nach A2 Wenn da auch nix ist Macht er A3*5


1
@jetzertle

danke, diese Formel ist vielversprechend. Werde ich mal mit Arbiten

0

Was möchtest Du wissen?