Einem Wort eine Zahl zuordnen in Excel

...komplette Frage anzeigen

2 Antworten

eine Einzel-Umwandlung geht mit

=VERGLEICH(A1;{"ja"."nein"."sonstwas"."weiteres"};0)

(hab ich mir erst gestern wieder von AugsburgChris in Erinnerung rufen lassen)
also:

ja ==>> 1
nein ==>> 2
sonstwas ==>> 3
weiteres ==>> 4

willst Du #NV! bei anderen Einträgen unterdrücken, dann (in xlsx):

=WENNFEHLER(VERGLEICH(A1;{"ja"."nein"."sonstwas"."weiteres"};0);0)

bzw im xls-Format:

=WENN(ISTFEHLER(VERGLEICH(A1;{"ja"."nein"."sonstwas"."weiteres"};0));0;VERGLEICH(A1;{"ja"."nein"."sonstwas"."weiteres"};0))

Anstrelle der allerletzten 0 kannst Du natürlich auch etwas anderes ausgeben lassen, zB 1000 (dann fällts bei einer Summe auf) oder "nicht vorgesehen" als Text

Iamiam 11.06.2014, 13:33

Bei der Formel für xls ist nicht die allerletzte 0 zu ersetzen sondern die mittlere (dann-Argument):

=WENN(ISTFEHLER(
VERGLEICH(A1;{"ja"."nein"."sonstwas"."weiteres"};0));"nicht vorgesehen";
VERGLEICH(A1;{"ja"."nein"."sonstwas"."weiteres"};0))

0

Du kannst mit der ZÄHLENWENN-Funktion alle Vorkommen eines Textes in einem Bereich zählen lassen.

Angenommen, Du hast im Bereich A1:A5 untereinander stehen

  • Ja
  • Nein
  • Nein
  • Nein
  • Ja

..dann kannst Du die beiden Formeln nutzen:

  • =ZÄHLENWENN(A1:A5; "Ja")
  • =ZÄHLENWENN(A1:A5; "Nein")

..was dann 2 und 3 ergibt :-)

henky123 11.06.2014, 10:30

Super!! Ich danke dir!!! Ich hab da noch ne Frage... kann ich auch bei einem "Ja" das Feld als grün markieren lassen?

0
Twitizen 11.06.2014, 10:38
@henky123

Kein Problem :-)

Das Einfärben wiederum geht ganz anders, und zwar über "Bedingte Formatierung". Einfach mal den ganzen Wertebereich markieren, die "Bedingte Formatierung" im Menü suchen, und dann (je nach Excel-Version) die Option "Zellen formatieren, die folgenden Text enthalten" verwenden.

Mit den Formatoptionen kannst Du dann rumspielen, bis Du rote/grüne/blaue/rosa Zellen hast :-)

1

Was möchtest Du wissen?