eine Frage zu Excel (calc)?

... komplette Frage anzeigen

3 Antworten

Muss es unbedingt ein "X" sein?

Wenn es auch eine Zahl sein kann, z. B. 0, kannst du die Funktion SUMMEWENNS verwenden.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Andi71193
13.02.2016, 16:06

kann das X durch ne null ersetzen kein problem ;) das bringt mich schonmal weiter, aber mit summewenns, kann ich so wie ich das bisher beurteilen kann nur sagen er soll addieren wenn zu einem Feld ein Bezug steht, er soll aber eben addieren wenn in diesem Feld nix steht.

0

Es geht auch mit einem x.
Und vorzugsweise mit SUMMEWENN:

=SUMMEWENN(E4:E40;"<>x";D4:D40)

Ich persönlich löse solche Aufgaben aber lieber mit SUMMENPRODUKT, da das flexibler und imho übersichtlicher ist. Ist aber Geschmackssache.
Bei SEHR großen Bereichen KÖNNTE es die Performance ETWAS beeinflussen.

=SUMMENPRODUKT((E4:E40<>"x")*(D4:D40))

Antwort bewerten Vielen Dank für Deine Bewertung

Das x wird sowieso nicht mitgezählt!

Schreib in A1 1, A2 2, A3 3 usw bis A10 10 rein. Die  Summe ist 55

Schreib  in einer Zelle x rein und du wirst sehen, das sich die Summe ändert

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
13.02.2016, 16:36

(= SUMME(D4:D40))

bei denen in Spalte E ein "X" steht

0

Was möchtest Du wissen?