Ecxelformel um nach Datum zu suchen?

...komplette Frage anzeigen

4 Antworten

=Summenprodukt((Ganzzahl(A1:A999)=1*"16.7.17")*1) zählt alle Einträge am 16.7.17

=Summenprodukt((Ganzzahl(E19:E26)=1*"16.7.17")*(B1:B999="Dein Suchtext"))

ich empfinde die Summenprodukt-Formel mit Logik-Komponenten einfach anschaulicher als ZählenwennS, dessen Syntax ich mir nicht zusätzlich merken mag. Und "DatumZeit"*1 ist eine der wenig wirklich sinnvollen Neuerungen in xl, schon nicht mehr ganz neu.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
16.07.2017, 00:51

da sind mir zwei Bereiche durcheinandergekommen. Muss natürlich auch in der zweiten Formel A1:A999 heissen

Und A:A bzw B:B ist auch möglich.

0

=ZÄHLENWENNS(A:A;">=01.03.2017";A:A;"<02.03.2017")

=ZÄHLENWENNS(A:A;">=01.03.2017";A:A;"<02.03.2017";B:B;"Durchgeführt")

Antwort bewerten Vielen Dank für Deine Bewertung

Da hast Du etwas "zuviel des Guten" gemacht.

=ZÄHLENWENN(A:A;"01.03.2017")

reicht vollkommmen.
Für zwei Kriterien:

=ZÄHLENWENNS(A:A;"01.03.2017";B:B;"Durchgeführt")

Klappt es?

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Oubyi
15.07.2017, 22:54

P.S.: Sorry, das mit der Uhrzeit war mir entgangen und ein Bild ist leider auch  nicht zu sehen. Wenn die Uhrzeit mit erfasst ist, muss es heißen:

=SUMMENPRODUKT(((ABRUNDEN(A1:A100;0))=(DATWERT("01.03.2017")))*1)

0

Warum so kompliziert?

=ZÄHLENWENN(A:A;B1)

mit den gesuchten Datum in B1.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von manureindl1998
15.07.2017, 19:46

das wird nicht klappen, da die ja die uhrzeit noch mitdrin steht

0
Kommentar von MatthiasHerz
15.07.2017, 19:51

Hast es probiert?

0

Was möchtest Du wissen?