Dynamisches Routing im Paket-Tracer?

...komplette Frage anzeigen

3 Antworten

Zunächst für alle anderen, die bisher geantwortet haben: Packettracer ist ein Stück Software von Cisco, mit dem man Cisco-Geräte simulieren kann. Sie dient in erster Linie als Übungsumgebung für die Vorbereitung auf die Zertifizierung als CCNA.

Zur Frage: Ganz einfach indem man es konfiguriert, wie man es auf einem "echten" Cisco-Router auch konfigurieren würde:

Starten des Routingprozesses:

(config)#router <protokollabhängige Parameter>

Festlegen der Interfaces, die am Routingprozess teilnehmen:

(config-router)#network

Eventuell noch weitere, teilweise Protokollspezifische Parameter einstellen.

Die Spielregeln der Routingprotokolle müssen natürlich eingehalten werden, also z.B. bestimmte Parameter auf beiden Routern, die sich unterhalten sollen, gleich konfigurieren.

Beispiel für RIP:

Es gibt die Interfaces fa0/0, 192.168.1.1; fa0/1, 10.1.1.1; s0/0, 172.16.1.1

(config)#router rip

(config-router)#network 192.168.1.0

(config-router)#network 10.0.0.0

(config-router)#network 172.16.0.0

Hier werden im network-Befehl die Klassennetze angegeben. Wenn RIPv2 laufen soll, noch zusätzlich:

(config-router)#version 2

(config-router)#no auto-summary

Für EIGRP:

(config)#router eigrp 100 !Die AS-Nummer muss auf allen Routern gleich sein

(config-router)#network 192.168.1.0

(config-router)#network 10.0.0.0

(config-router)#network 172.16.0.0

(config-router)#no auto-summary !Ab IOS15 ist das default

Alternativ kann man anstelle der Klassennetze im EIGRP auch die Interfaces genauer definieren mit einer Wildcard oder der Subnetzmaske. Ob der Packettracer die Subnetzmaske annimmt, musst Du ausprobieren.

(config-router)#network 172.16.1.1 0.0.0.0

Für OSPF:

(config)#router ospf 1 !lokale Prozessnummer muss nicht auf allen Routern gleich sein

(config-router)#network 192.168.1.1 area 0

(config-router)#network 10.1.1.1 area 0

(config-router)#network 172.16.1.1 area 1

Im OSPF sind natürlich gerade bei den Areas viele verschiedene Varianten möglich. Zusätzlich kann man in allen Protokollen z.B. maximum-paths setzen und weitere teils protokollspezifische Parameter konfigurieren. Welche vom Packettracer unterstützt werden, musst Du ausprobieren. Das ist ja schließlich eine Simulation und kein echtes IOS. Unter cisco.com und mit Google findest Du massenhaft Informationen zu den Protokollen und zur Konfiguration unter Cisco. Alternativ: ICND-Kurse besuchen.

Diese Frage verwirrt :-) Kannst du mit (einfachen Worten) nochmals beschreiben, was genau du machen/wissen willst? Im Moment tönt die Frage für mich eher so, als ob du selber ein Programm wie den "tracert" schreiben willst, aber nicht weisst, wie das technisch funktioniert (ICMP,....)....

Was verstehts du unter dynamischem Routing? Normalerweise machen die Router das untereinander aus, wie das Paketchen laufen soll. Auf den Weg hast du also eigentlich schon ohne etxra Arbeit keinen Einfluss.

Was möchtest Du wissen?