Datum automatisch auflisten in excel

...komplette Frage anzeigen

4 Antworten

Ich schätze, Du willst ALLE Tage des angegebenen Monats aufgelistet haben, oder?

Eigentlich gar nicht so schwer, bloß die unterschiedliche Anzahl Tage in den Monaten könnte etwas knifflig werden. Also: Erstmal brauchst Du die Funktion DATUM. Die baust Du dir in Zelle A4 so zusammen: =DATUM($C$2;$C$1;1) Damit hast Du den ersten Tag. Dann kannst Du in den Zellen darunter einfach hoch zählen, also in Zelle A5: =A4+1 Jetzt kommt das knifflige: Wenn Du bei Monaten mit weniger als 31 tagen in den Zellen A32, A33 und A34 keine Ergebnisse für den nächsten Monat haben willst, musst Du dort prüfen, ob Du noch im angebenen Monat bist. D.H. für Zelle A32:=WENN(MONAT(A31+1)=$C$1;A31+1;"") A33:=WENN(MONAT(A31+2)=$C$1;A31+2;"") A34:=WENN(MONAT(A31+3)=$C$1;A31+3;"")

Soweit das Datum. Gleich schreib ich Dir noch was zu den Wochentagen.

Danke für die Antwort. aber warum schreibt mir excel in A4 #Wert

0
@jodler70

was steht denn bei Dir in Zelle C1 und C2? Ich habe da einfach den Monat (als Zahl) und das Jahr eingetragen. Dann geht's.

Die Funktion DATUM brauch Jahr, Monat und Tag als Zahl.

1
@OpaWetterwachs

Weil dann in der Formel irgendwas nicht stimmt oder in den Zellen C1, C2 etwas falsches steht, z.B etwas nicht numerisches.

Die Formel von OpaWetterwachs ist jedenfalls richtig.

0
@ProRatione

hab das monat ausgeschrieben. wenn ich es als zahl eingebe dann klappt es auch. ist es text auch möglich?

0
@jodler70

Ja, das geht. Man muss allerdings Excel ein Bisschen austricksen.

Damit es nicht zu unübersichtlich wird, erkläre ich das mal losgelöst von deiner eigentlichen Frage.

Nimm mal an, Du hast in Zelle E1 den Monat als Text. Dann schreibst Du in Zelle C1 (in der der Monat als Zahl stehen soll): =MONAT(DATWERT(E1&" 2014"))

Der Trick ist, dass an den Monat eine Jahreszahl angeklebt wird (mit &" 2014"), dann erkennt Excel diesen Text als Datumsangabe. Jetzt muß man aus dieser Datumsangabe nur noch den Monat wieder auslesen, das macht die Funktion MONAT.

1
@OpaWetterwachs

Ach danke super. diese zwischenzelle kann ich ja dann ausblenden und man sieht diese Zahl nicht sondern nur das geschriebene monat.

Wenn ich mal wieder fragen habe dann melde ich mich wieder bei euch.

0
@jodler70

Du kannst natürlich die Formel, die aus dem Monatstext eine Monatszahl macht auch in die Spalte A einbauen. Dann werden die Formeln dort aber so langsam unübersichtlich. In A4 stünde dann z.B.:

=DATUM($C$2;MONAT(DATWERT($E$1&" 2014"));1)

und so weiter.

Diese Schachtelei von Funktionen ist im Excel wirklich nicht besonders übersichtlich gemacht, das war in früheren versionen schonmal besser.

0

So, hier der zweite Teil.

Erstmal machst Du mit WOCHENTAG aus dem Datum eine Zahl und dann mit WAHL aus der Zahl einen Text aus der Liste. Das sieht dann so aus (beispiel für Zelle B4, dann runter kopieren): =WAHL(WOCHENTAG(A4;2);"MO";"DI";"MI";"DO";"FR";"SA";"SO")

Am Ende der Liste musst Du wieder prüfen, ob in Spalte A überhaupt etwas drin steht, also: B32: =WENN(A32="";"";WAHL(WOCHENTAG(A32;2);"MO";"DI";"MI";"DO";"FR";"SA";"SO")) und so weiter.

Alles klar?

Den Wochentag kannst du auch folgendermaßen bestimmen:

=TEXT(WOCHENTAG(A4); "TTT") -> Ausgabe Do

=TEXT(WOCHENTAG(A4); "TTTT")-> Ausgabe Donnerstag

Was möchtest Du wissen?