Datentrasfer unter Windows 7 x64 (64 Bit) SP1 zwischen 2 Sata300-Festplatten

...komplette Frage anzeigen

2 Antworten

Die 300 MB/s sind nur ein theoretischer Wert, der maximal über die Schnittstelle geht. Da kommt aber keine Festplatte mit, weshalb das von daher schon mal wesentlich langsamer geht. Dann kommt es noch auf die Größe der zu kopierenden Dateien an.

30 MB/s sind aber trotzdem recht wenig. Es gibt ein Tool namens HD Tune, mit dem kannst du deine Platten mal testen.

http://www.chip.de/downloads/HD-Tune_23932256.html

Zakalwe 20.04.2011, 09:42

Nur so zur Info: Es gab wohl einen Firmwarefehler bei diesen Platten.

http://www.heise.de/ct/meldung/Firmware-Patch-fuer-Samsung-Festplatte-EcoGreen-F4-HD204UI-Update-1150154.html

Wenn es aber ganz neue Platten sind, die dieses Jahr hergestellt wurden, dürfte der Fehler bereits behoben sein.

0
BorstiWE 20.04.2011, 10:19
@Zakalwe

Vielen Dank für den Tipp.

Das Problem ist mir auch bekannt.

Die Platten haben das Produktionsdatum 02/2011 und ich hoffe somit, dass die neue Firmware auch drauf ist, was man leider nicht an der Versionsnummer erkennen kann und ich wollte die Platten nicht auf bloßen Verdacht flashen, weil dadurch die Garantie erlöschen könnte.

 

0
BorstiWE 20.04.2011, 10:15

OK, Everest gibt mir für die Leseplatte einen Random-Read-Wert von 93 MB/s aus, der seinen fatalsten Wert im End-Read von nur 46 MB/s findet.

Auf dieser Platte wird auch nur gelesen.

Um die Frage anfangs nicht unnötig zu komplizieren hatte ich verschwiegen, dass mein Kopierziel aber ein schnelles Raid5 mit 4 Platten dieses Typs ist.

Hierfür gibt Everest einen Random-Read-Wert von 204 MB/s mit einem End-Read von 174 MB/s aus. (die Write-Werte kann ich nicht ermitteln, weil Everest beim Write-Test die Daten auf dem zu testenden Medium zerstört und sich hier nun mal auch Windows ein wenig breit gemacht hat.)

Und ich kann es kaum fassen (denn ich habe für diese Konfiguration insgesamt ca. 250 € mehr ausgegeben) wenn ich innerhalb des Raid5-Volumes kopiere, sackt meine Datentransferrate sogar noch auf ca. 20 MB/s ab.

Durch diese Raid-Konfiguration kann ich im Bios den SATA-Betriebsmodus aber nicht auf AHCI einstellen, denn dieser steht auf RAID-Mode, was ich wohl auch brauche, wenn ich ein Raid-Array betreiben will.

So weit ersteinmal.

Weitere Erklärungs- und Lösungs-ansätze werden aber noch gerne gelesen und wenn möglich auch ausprobiert ;-)

Vielen Dank für Euer Engagement.

 

0
Zakalwe 20.04.2011, 12:30
@BorstiWE

Mir RAID kenne ich mich nicht wirklich aus. Ich habe nur folgendes gelesen: Die Schreibgeschwindigkeit ist langsamer, da immer auch ein Lesezugriff erfolgen muss. Ausserdem sollen Onboard Raid Systeme relativ lahm sein, da der Controller nicht sonderlich gut ist. Vielleicht liegt hier der Hund begraben. Weiter kann ich dir in dem Punkt aber nicht helfen.

0
BorstiWE 20.04.2011, 13:47
@Zakalwe

Vielen Dank für Deine Gedanken.

Selbstverständlich kann ein Onboard-Raid-Controller eines Mainboards für insgesamt 180,- € nicht so gut sein, wie ein diskreter Raid-Controller für 500,- €, aber dass von gemessenen 204 MB/sec sogar NOCH weniger übrig bleibt, als bei Single-SATA ist doch mehr als ernüchternd.

So langsam bekomme ich Zweifel am Windows7 x64, dass mit der Hardware wohl noch nicht optimal umgeht.

Theoretisch sollte ein Raid5 mit 4 Platten ca. 3 mal so schnell sein, wie eine Einzelplatte und das käme mit den Messwerten von 93 MB/sec auf 204 MB/sec (240 MB/sec in der Spitze) über den wirklich dicken Daumen ja auch fast hin. *hüstl*

Wenn sich das Verhältnis unter Windows 7 wenigstens auch so fortschreiben würde, wäre ich ja auch nicht ganz so unglücklich über meine Mehrausgabe von 250,- € für dieses Raid.

0

Lesen, schreiben, überprüfen. Das sind die Arbeitsgänge beim Kopieren. Dazu kommt noch die Lese- und Schreibgeschwindigkeit der Festplatten und die Fragmentierung der zu kopierenden Platte. Schwupps, und schon wird's langsam.

BorstiWE 20.04.2011, 09:14

Danke für die Antwort, aber rechnen wir doch mal nach:

Lesen 300 MB/s auf Platte 1

Schreiben 250 MB/s auf Platte 2

Prüfen 300 MB/s auf beiden Platten.

Also wird auf der einen Platte maximal doppelt gelesen = die Hälfte von 300 MB/s = 150 MB/s

Auf der anderen Platte wird geschrieben und gelesen, also einigen wir uns mal auf die Hälfte von 250 MB/s = 125 MB/s

Der Flaschenhals ist also die Empfänger-Platte mit ca. 125 MB/s, die im Übrigen ebenfalls nigel-nagel-neu ist und komplett LEER, weshalb Fragmentierung hier gar keine Rolle spielen dürfte.

Da sind 30 MB/s aber immer noch nur 1/4 der aus meiner Logik entspringenden 125 MB/s.

Sorry, aber diese Antwort kann mich leider nicht befriedigen.

Trotzdem vielen Dank, dass Du Dich meines Themas angenommen hast.

 

0
DerMuffti 20.04.2011, 09:29
@BorstiWE

Rechnerisch fährt mein Auto auch 180 Km/h. Wird aber in den seltensten Fällen erreicht. Deine Werte sind theoretische Werte unter Laborbedingungen. Und wann treffen die schon mal den Punkt: Beispiel nochmals KFZ und der angegebene Spritverbrauch. Trifft auch nie zu. Nochmals zur Fragmentierung: ich schrieb: Fragmentierung der zu kopierenden Platte. Also die sendende. Nebenbei und in meiner Antwort nicht berücksichtigt ist das dein Rechner so ganz nebenbei auch noch andere Arbeiten, auch auf dem SATA.Bus, erledigt.

0
BorstiWE 20.04.2011, 10:34
@DerMuffti

Vielen Dank für Deine Geduld mit mir ;-)

Mittlerweile glaube ich auch, dass hier von den Plattenherstellern ganz schön an den Werten "geschönt" wird, genau so wie 1 TB ja auch plötzlich "nur" aus 1.000.000.000.000 Byte bzw. 1.000 GB besteht.

"Hugh", der Kaufmann hat gesprochen und nur der Techniker weiß, dass 1 TB aus 2^40 Byte bzw. aus 2^10 GB = 1024 GB besteht.

Trotzdem kann bei meinem Problem die Fragmentierung keine all zu große Rolle spielen, denn gerade die zu kopierende Platte enthält mein Video-Roh-Archiv, dass nur ein mal draufgespielt wird und wenn die Platte voll ist kommt sie in den Schrank. (selbstverständlich nicht bevor ich einen Stapel DVD´s davon gebrannt habe und diesen zu Oma gebracht habe ;-)))

OK, und bitte WAS trödelt mein Rechner da noch so auf dem SATA-Bus herum? *lol*

0
DerMuffti 20.04.2011, 11:41
@BorstiWE

Nun ja, so ein DVD - Laufwerk z.B. welches zwar nichts zu tun, dennoch ständig das " hier sein" meldet. Ach fällt mir gerade ein: Hast du einen Virenscanner? Mit Sicherheit. Tja und der Kerl überprüft auch jede Datei, die bewegt, geöffnet oder auf die zugegriffen wird.

0
BorstiWE 20.04.2011, 14:03
@DerMuffti

Nein, ein Viren-Scanner ist noch nicht drauf, weil ich das System ja gerade erst aufgesetzt habe, damit auch noch nicht online bin und nur die originale SW von den Hersteller-Scheiben installiert habe.

Alles was aus dem Netz kommt (z.B. SP1) passiert meine Scanner auf meinem alten System, bevor es per USB-Stick auf den Neuen kommt.

Und der DVD-Brenner ist SATA1, kann also nur mit 150 MB/sec mit seinen Präsenzmeldungen dazwischenfunken, lol. Ausserdem steckt der bei mir sogar an SATA600, weil ich dafür (noch) keine andere Verwendung habe. (man gönnt sich ja sonst nix ;-)))

Bei mir liegen 4 Platte am SATA300-Controller und enthalten ein 1TB RAID10 und ein 4TB RAID5-Volume. Damit sind die 4 2TB-Platten voll ausgenutzt.

Am ersten SATA600-Port liegt die einzelne 2 TB-Platte, der zweiten SATA600 ist leer, am ersten Marvell-SATA600 liegt der SATA150-Brenner und der zweite Marvell-SATA600 ist leer.

0

Was möchtest Du wissen?