CSS Datei kann nicht auf HTML Skript zugreifen?

...komplette Frage anzeigen Hier der besagte Code.. - (html, CSS)

3 Antworten

Link-Tag am Ende mit einer spitzen Klammer (>)  schließen und die Leerzeichen zwischen den einzelnen Attributen entfernen. Da von dir der HTML5 Doctype verwendet wird, das Type-Attribut auch weg lassen kannst. 

<!doctype html>
<html lang="de">
 <head>
  <meta charset="utf-8">
  <title>CSS-Tutorial</title>

  <link rel="stylesheet" href="style.css">
 </head>
...

LG medmonk 

ma9rtin 16.02.2017, 18:39

Danke für deine Mühe, allerdings geht es immer noch nicht.. komisch

0
medmonk 17.02.2017, 16:50
@ma9rtin

Dann machst du etwas verkehrt. Entweder ist irgendwo ein Tippfehler vorhanden oder der Verweis (Link) zu deinem Stylesheet stimmt nicht. Überprüf also nochmal, ob es korrekt ist. Im Anhang habe ich dir ein simples Template hochgeladen. Einfach das Zip-Archiv herunterladen, entpacken und damit weiterarbeiten.  

0
ma9rtin 20.02.2017, 10:04

Du wirst es mir nicht glauben, aber selbst damit wird der Hintergrund nicht rot... HTML funktionier problemlos, aber css nicht../

0
medmonk 20.02.2017, 16:46
@ma9rtin

Dann machst du definitiv etwas verkehrt. Schreib folgendes ins CSS:

body {
 background-color: red;
}

Überprüf deine Schreibweise oder kopier einfach mein Snippet ins CSS. 

LG medmonk

0

Du hast bei <link ref (...) am Ende ein > vergessen!

ma9rtin 15.02.2017, 20:27

Du hast recht.. ich habs übersehen, dummling.. Danke dir! Werd es gleich ausprobieren

0
der2000erTyp 15.02.2017, 20:27
@ma9rtin

Dass da ein Fehler ist, siehst du auch daran, dass "</head>" rot ist.

0
ma9rtin 15.02.2017, 20:28

Hey! Es geht trotzdem nicht :::(((((

1
ma9rtin 15.02.2017, 20:33

Es geht immernoch nicht... muss man da noch irgendwas beachten? Ist mit dem CSS Code alles ok?

1
der2000erTyp 15.02.2017, 20:35
@ma9rtin

Du hast bei style.css noch nicht gespeichert! Mach mal das "lang = de" bei html weg. VLlt funktionierts dann ja

0
ma9rtin 15.02.2017, 20:39

Fehlanzeige.. ich hab kein Plan mehr

0
der2000erTyp 15.02.2017, 20:41
@ma9rtin

Fang mal einfach ein neues Projekt an (: und lass die Grundstruktur, bei netBeans

0
ma9rtin 15.02.2017, 20:58

Ok.. ich danke dir vielmals für deine Hilfe ;)

0

Irre ich mich oder sollte es nicht background-color heissen wenns einfarbig sein soll

ma9rtin 16.02.2017, 16:38

Ich hab mir ein Tutorial angeschaut und war es auch so

0
LeonardM 16.02.2017, 16:41

okay aber die style.css hast du schon abgespeichert zum zeitpunkt des tests oder? weil aufm screen wurde noch nicht abgespeichert vom sehen her

0
LeonardM 16.02.2017, 16:44

ps: teste mal background-color statt nur background. ich habe grade mal nen kollege gefragt der vorwiegend mit css zutun hat und der meint es wäre background-color

0
ma9rtin 16.02.2017, 18:38

Hab alles abgespeichert, auch mit background-Color und es geht immernoch nicht... wahnsinn

0
LeonardM 16.02.2017, 18:44

merkwürdig. dann würde mir nurnoch der cache einfallen.. schau mal im Browser ob änderungen übernommen wurden

0
LeonardM 16.02.2017, 18:46

naja link hast du nicht beendet und ich würde keine leerzeichen an deiner stelle verwenden zb bei href = "url" sondern href="url". bei allem anderen auch nach dem prinzip

0

Was möchtest Du wissen?