Chestshop lösung gesucht?

3 Antworten

Moin Chaos53925,

das Problem hatte ich auch. Wechsel mal auf die #build27. Die neueren Versionen haben alle Fehler.

Bei mir läuft chestchop unter der 1.12.2 fehlerfrei.

Alternativ auch protocollib installieren und vor allem vault akuell halten. Chestshop läuft nur auf SQLlight nicht auf MySQl.

Da es in der 1.12.2 keine gravierenden Änderungen gab wäre es noch möglich die 1.12 zu verwenden und mit viaversion den Zugang auch mit 1.12.2 zu ermöglichen.

In zukünftigen Minecraft Versionen ab 1.13 wird es sehr wahrscheinlich erneute Probleme geben.

Viel Glück und Grüße von katzebiggi

Danke für den tipp. Ich werde es ausprobieren

0

Leider hat dies nicht funktioniert

0
@Chaos53925

Hätte jetzt noch die Idee mal alle Plugins, ausser pex, worldedit, vault und protocollib, runter nehmen und sehen ob chestchop dann startet.

Möglich wäre, dass es mit iconomy6 nicht kompatibel ist. Hier wäre die Alternative essentials.

Wenn chestchop ohne der anderen plugins startet, dann eins nach dem Anderen wieder rein und sehen. wann der Fehler kommt.

Ist zwar etwas aufwändig, hast mir aber schon sehr oft geholfen.

Grüsse von katzebiggi

0

Hätte noch die Idee mal alle plugins. ausser worldedtit, pex, vault und porotocollib runter nehmen und sehen ob chestchop dann startet.

Wenn ja, dann ein Plugin nach dem Anderen wieder rein und sehen wann der Fehler kommt.

Es könnte sein, das chestchop mit iconomy6 nicht kompatibel ist. Alternative wäre essentials.

Ist zwar etwas aufwändig, hat mir aber schon oft geholfen.

Grüsse von katzebiggi

0

Serverversion? Pluginversion?

Andere installierte Plugins? Passende Datenbank?

Wo hostest du den Server?

Server Version Spigot 1.12.2

Plugin version ist die neueste (vom Author selbst gegebene Seite) von https://ci.minebench.de/job/ChestShop-3/

Plugins: MSG, CustomHelpMessage, AdvancedBans, ChatEX, ControlTPA, CustomServerMessage, HomeSpawn, iConomy 6, ItemTagger, LagMeter, LogBlock, LWC, OpenInv, PermissionsEX, PlugMan, PvPControl, Vault, WorldEdit

bei Chestshop konnte ich die Datenbanken nie von sqlite auf mySQL umstellen.

Ich kann bei meinem Hoste Zap-Hosting bis zu 10 mySQL Datenbanken anlegen

0

Das Plugin stimmt nicht mit deiner Server-Version überein.

0

was kann ich da machen? kann ich das selbst irgendwie beheben?

bzw. kennst du eine gute und ähnliche alternative?


0

Ich würde sagen ChestShop gibt es nicht für Minecraft 1.12.2

Schade... wäre auch zu schön gewesen

0

Hilfe mit umgeschriebenen Plugin?

Hallo habe das Plugin PromotionEssentials umgeschrieben!

Bei mir kommt allerdings diese Fehlermeldung!

Bitte um Hilfe, von Leuten die gut Plugins schreiben können...

[20:25:53 ERROR]: Could not load 'plugins\PromotionEssentials1.jar' in folder 'plugins'

org.bukkit.plugin.InvalidPluginException: main class `me.tekkitcommando.PromotionEssentials.MasterPromote' does not extend JavaPlugin

    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:73) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:292) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:198) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:525) [spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

    at java.lang.Thread.run(Unknown Source) [?:1.8.0_131]

Caused by: java.lang.ClassCastException: class me.tekkitcommando.PromotionEssentials.MasterPromote

    at java.lang.Class.asSubclass(Unknown Source) ~[?:1.8.0_131]

    at org.bukkit.plugin.java.PluginClassLoader.<init>(PluginClassLoader.java:71) ~[spigot-1.8.8.jar:git-Spigot-db6de12-18fbb24]

...zur Frage

Hallo ich habe ein Minecraft-bukkit-plugin Programmiert in Eclipse bekomme ich keine fehler aber in der Konsole (Das Plagin ist ein InvetarKitsPlugin) Error:?

[15:50:14 ERROR]: Could not pass event InventoryCreativeEvent to ItemsKit v1.0 org.bukkit.event.EventException at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja va:302) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav a:62) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.j ava:501) [bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.j ava:486) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PlayerConnection.a(PlayerConnection.java :1710) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PacketPlayInSetCreativeSlot.a(SourceFile :23) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PacketPlayInSetCreativeSlot.a(SourceFile :9) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.PlayerConnectionUtils$1.run(SourceFile:1 3) [bukkit.jar:git-Bukkit-18fbb24] at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [ ?:1.8.0_71] at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_71] at net.minecraft.server.v1_8_R3.SystemUtils.a(SourceFile:44) [bukkit.jar :git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.B(MinecraftServer.java:6 73) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.DedicatedServer.B(DedicatedServer.java:3 35) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.A(MinecraftServer.java:6 29) [bukkit.jar:git-Bukkit-18fbb24] at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java :537) [bukkit.jar:git-Bukkit-18fbb24] at java.lang.Thread.run(Unknown Source) [?:1.8.0_71] Caused by: java.lang.IllegalArgumentException: Specified enchantment cannot be a pplied to this itemstack at org.bukkit.inventory.ItemStack.addEnchantment(ItemStack.java:440) ~[b ukkit.jar:git-Bukkit-18fbb24] at Kits.Kits.Inventory(Kits.java:31) ~[?:?] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:1.8.0 _71] at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:1.8.0 _71] at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[?:1 .8.0_71] at java.lang.reflect.Method.invoke(Unknown Source) ~[?:1.8.0_71] at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja va:300) ~[bukkit.jar:git-Bukkit-18fbb24] ... 15 more [15:50:15 ERROR]: Could not pass event InventoryCreativeEvent to ItemsKit v1.0 org.bukkit.event.EventException at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.ja va:302) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.jav a:62) ~[bukkit.jar:git-Bukkit-18fbb24] at org.bukkit.plugin.Si

...zur Frage

Kann jemand diesen Fehlercode lesen?

Es ist eine Bukkit Plugin das ich schreibe. hier der Fehlercode aus dem log:

[17:20:19] [Server thread/ERROR]: Could not load 'plugins\test.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.UnsupportedClassVersionError: me/Hauke/main/main : Unsupported major.minor version 52.0 at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:135) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:329) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:251) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugins(CraftServer.java:291) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at net.minecraft.server.v1_8_R2.DedicatedServer.init(DedicatedServer.java:199) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java:522) [craftbukkit.jar:git-Spigot-dbe012b-61ef214] at java.lang.Thread.run(Unknown Source) [?:1.7.0_04] Caused by: java.lang.UnsupportedClassVersionError: me/Hauke/main/main : Unsupported major.minor version 52.0 at java.lang.ClassLoader.defineClass1(Native Method) ~[?:1.7.0_04] at java.lang.ClassLoader.defineClass(Unknown Source) ~[?:1.7.0_04] at java.security.SecureClassLoader.defineClass(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader.defineClass(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader.access$100(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_04] at java.net.URLClassLoader$1.run(Unknown Source) ~[?:1.7.0_04] at java.security.AccessController.doPrivileged(Native Method) ~[?:1.7.0_04] at java.net.URLClassLoader.findClass(Unknown Source) ~[?:1.7.0_04] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:101) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:86) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_04] at java.lang.ClassLoader.loadClass(Unknown Source) ~[?:1.7.0_04] at java.lang.Class.forName0(Native Method) ~[?:1.7.0_04] at java.lang.Class.forName(Unknown Source) ~[?:1.7.0_04] at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.java:64) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:131) ~[craftbukkit.jar:git-Spigot-dbe012b-61ef214]

...zur Frage

Eigenes Plugin Crash bitte Hilfe!?

Hey Ich habe heute mein Erstes Plugin mit java Programmiert und ich finde es toll,

ich wollte es ausprobieren aber die console zeigte andauernd diese Fehler Meldung :C bitte Hilfe :

[20:29:21 ERROR]: Could not load 'plugins/Heal.jar' in folder 'plugins'

org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml

at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPluginLoader.java:162) ~[craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:133) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.loadPlugins(CraftServer.java:289) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at org.bukkit.craftbukkit.v1_8_R3.CraftServer.<init>(CraftServer.java:251) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.PlayerList.<init>(PlayerList.java:69) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.DedicatedPlayerList.<init>(SourceFile:14) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.DedicatedServer.init(DedicatedServer.java:179) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at net.minecraft.server.v1_8_R3.MinecraftServer.run(MinecraftServer.java:504) [craftbukkit-1.8.8.jar:git-Bukkit-e1ebe52]

at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]

Caused by: org.yaml.snakeyaml.scanner.ScannerException: while scanning for the next token

found character '\t(TAB)' that cannot start any token. (Do not use \t(TAB) for indentation)

in 'reader', line 9, column 1:

...zur Frage

Wo liegt mein Fehler Minecraft Java Plugin Spigot?

Was Mache ich falsch?

[01:05:40 ERROR]: Could not load 'plugins\Zombie.jar' in folder 'plugins' org.bukkit.plugin.InvalidPluginException: java.lang.NullPointerException at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j ava:135) ~[craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager. java:329) ~[craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager .java:251) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.loadPlugins(CraftServer.ja va:291) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.reload(CraftServer.java:74 4) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.Bukkit.reload(Bukkit.java:534) [craftbukkit.jar:git-Spigot -1d14d5f-ba32592] at org.bukkit.command.defaults.ReloadCommand.execute(ReloadCommand.java: 25) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:14 1) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.dispatchCommand(CraftServe r.java:646) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.craftbukkit.v1_8_R2.CraftServer.dispatchServerCommand(Craf tServer.java:632) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at net.minecraft.server.v1_8_R2.DedicatedServer.aN(DedicatedServer.java: 405) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at net.minecraft.server.v1_8_R2.DedicatedServer.A(DedicatedServer.java:3 69) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at net.minecraft.server.v1_8_R2.MinecraftServer.z(MinecraftServer.java:6 51) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at net.minecraft.server.v1_8_R2.MinecraftServer.run(MinecraftServer.java :554) [craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at java.lang.Thread.run(Unknown Source) [?:1.7.0_67] Caused by: java.lang.NullPointerException at at.roboalex2.zombie.mainapp.(mainapp.java:57) ~[?:?] at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) ~[?:1.7.0_67] at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source) ~[?:1.7.0_67] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Sou rce) ~[?:1.7.0_67] at java.lang.reflect.Constructor.newInstance(Unknown Source) ~[?:1.7.0_6 7] at java.lang.Class.newInstance(Unknown Source) ~[?:1.7.0_67] at org.bukkit.plugin.java.PluginClassLoader.(PluginClassLoader.jav a:76) ~[craftbukkit.jar:git-Spigot-1d14d5f-ba32592] at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.j ava:131) ~[craftbukkit.jar:git-Spigot-1d14d5f-ba32592] ... 14 more

Es wird die selbe Spigot Version zum coden benutzt wie auch am Server leuft! Keine anderen Plugins und 8Gb ram!

...zur Frage

Minecraft Server Konsole LWC und ChestShop machen Probleme Lösung?

Habe hier einige Prtobleme mit den beiden Plugins und weiss sie nicht zu lösen. Hier die Logs.

[18:32:16 WARN]: [LWC] Plugin LWC v4.4.0 (b881) (July 11, 2013) generated an exception while executing task 4938

java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()[Lorg/bukkit/entity/Player;

at com.griefcraft.util.Metrics.postPlugin(Metrics.java:335) ~[?:?]

at com.griefcraft.util.Metrics.access$400(Metrics.java:57) ~[?:?]

at com.griefcraft.util.Metrics$1.run(Metrics.java:223) ~[?:?]

at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-server.jar:git-Spigot-7754231-9a1f5ee]

at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:52) [spigot-server.jar:git-Spigot-7754231-9a1f5ee]

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_151]

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_151]

at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]

>[18:32:16 WARN]: [ChestShop] Plugin ChestShop v3.8.12 generated an exception while executing task 5069

java.lang.NoSuchMethodError: org.bukkit.Server.getOnlinePlayers()[Lorg/bukkit/entity/Player;

at com.Acrobot.ChestShop.Metrics.postPlugin(Metrics.java:335) ~[?:?]

at com.Acrobot.ChestShop.Metrics.access$400(Metrics.java:57) ~[?:?]

at com.Acrobot.ChestShop.Metrics$1.run(Metrics.java:223) ~[?:?]

at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftTask.run(CraftTask.java:71) ~[spigot-server.jar:git-Spigot-7754231-9a1f5ee]

at org.bukkit.craftbukkit.v1_12_R1.scheduler.CraftAsyncTask.run(CraftAsyncTask.java:52) [spigot-server.jar:git-Spigot-7754231-9a1f5ee]

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:1.8.0_151]

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:1.8.0_151]

at java.lang.Thread.run(Thread.java:748) [?:1.8.0_151]

...zur Frage

Was möchtest Du wissen?