Braucht man PHP7?

...komplette Frage anzeigen

2 Antworten

PHP 5.6 ist sehr verbreitet und das wird sich in nächster Zukunft auch nicht ändern. Neuere Versionen werden erst nach und nach auf den Webhostern einzug nehmen und auch dann wird 5.6 noch auf Jahre hin supported werden. Es ist also durchaus nicht veraltet.

Eigentlich ist das egal. Mittelfristig wird PHP 7 zwar die 5.6er Version ablösen und es gibt sehr viele kleinere subtile Unterschiede bzw. neue Features, aber die kann man sich an einem Abend auch anhand der Docs selber beibringen, sofern man schon mal vernünftig PHP 5.x gelernt hat.

Mein letztes PHP-Buch war irgendwas mit der Version 3.x und seitdem bin ich mithilfe der Dokumentation auf dem Laufenden geblieben. :)

Hach jaaa ... PHP 3 ... das waren noch Zeiten ... ;)

ja das waren noch zeiten ohne PDO :/

0
@xBlackMass

Ja natürlich! Das mit PHP 3.x war nur eine Anekdote. Du solltest in jedem Fall mit PHP 5.6 oder 7 anfangen, ohne dich vorher durch die Geschichtsbücher arbeiten zu müssen! :)

0

Was möchtest Du wissen?