Brauche Hilfe mit VBA und Summewenn?

... komplette Frage anzeigen

2 Antworten

Zunächst musst Du die Spalte benennen, die summiert werden soll, danach folgen einzeln die Bereiche und Suchkritieren, die erfüllt sein müssen, damit das Summieren erfolgt - sieht etwas unlogisch aus, funktioniert aber.

Du hast, wenn ich die Frage richtig verstehe, ja zwei Tabellen. In die Tabelle, wo die Ergebnisse der Abfrage gespeichert werden, werden vermutlich ja die Datumsangeben stehen. Man kann also auf Spalte A (oder was anders) verweisen und braucht den Wert nicht fest im Code.

Tabelle1 wäre also die Datenquelle
Tabelle2 wo die Summen erstellt werden

Die Formel schreibt die Summe in Zelle B1 auf dem Tabellenblatt2 für das Datum in A1

Sheets("Tabelle2").Cells(1, 2).Value = WorksheetFunction.SumIfs(Sheets("Tabelle1").Range("B:B"), Sheets("Tabelle1").Range("D:D"), Sheets("Tabelle2").Range("A1").Value, Sheets("Tabelle1").Range("F:F"), "Aktiv", Sheets("tabelle1").Range("H:H"), "DER")

Alternativ geht das ganz aber auch per Formel
=SUMMEWENNS(Tabelle1!B:B;Tabelle1!D:D;A1;Tabelle1!F:F;"Aktiv";Tabelle1!H:H;"DER")

Vielleicht ist Dir das ja sympathischer

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jansabi
21.02.2016, 15:11

Vielen Dank für die schnelle Antwort. Ich werde es mal probieren. 

0

dass wenn in Spalte D das Datum gleich ist, in Spalte F Aktiv steht

Gleich mit was?

wenn in Spalte H DER steht die Summe von den Beträgen in Spalte B gebildet wird

 

Der Beträge von wo (2) bis x?

 

 

 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Jansabi
21.02.2016, 15:16

In Spalte D stehen verschiedene Datümer. Z.B. 23.6.16 und 24.6.16. Hier soll die Summe der Zeilen in Spalte B gebildet werden für das Datum 23.6.16 und danach für alle Zeilen wo der 24.6.16 drin steht und natürlich müssen die anderen beiden Bedingungen auch stimmen. Die Summen sollen dann mit dem jeweiligen Datum in eine andere Datei kopiert werden.

0

Was möchtest Du wissen?