Brauche Hilfe bei Excel :/ Komme leider nicht weiter..?

...komplette Frage anzeigen

3 Antworten

Also in Celle C 25 möchtest du als Ergebnis die Anzahl bekommen, wie oft ein bestimmter Name (welcher?) in Spalte B vorkommt.
Der entsprechende Excel Befehl ist: zählenwenn

Und was willst du als Text ausgeben?

Antwort bewerten Vielen Dank für Deine Bewertung

Ich habe noch nicht verstanden, was du willst.

Beispiel mit nur 3 Zeilen:
B1: "eins"
B2: "zwei"
B3: "drei"

C1: "Anton"
C2: "Berta"
C3: "Anton"

-> was soll in C25 nun ausgegeben werden?

Antwort bewerten Vielen Dank für Deine Bewertung

Zählen:


=Zählenwenn(C1:C20;"Dieter")

Alle "Texte" in B ausgeben, wo der Name gefunden wurde (untereinander)
Formel mit STRG+SHIFT+Enter abschließen! Die untere Formel anschließend runterziehen. Du kannst den Namen natürlich auch aus einer Zelle lesen.

=WENNFEHLER(INDEX($B$2:$B$20;KGRÖSSTE(($C$2:$C$20="Dieter")*(ZEILE($C$2:$C$20)-1);ZÄHLENWENN($C$2:$C$20;"Dieter")+1-ZEILE(B1)));"")
Antwort bewerten Vielen Dank für Deine Bewertung
Hadi1987 21.07.2016, 12:23

Das hilft mir schon viel weiter, jedoch kommt der Name jetzt 3 mal vor (C1,C2,C3) und er gibt mir nur B4 aus, dabei wäre es nett von Excel, wenn er mir B1,B2 und B3 ausgibt

:/

0
azmd108 21.07.2016, 12:29
@Hadi1987

?? du musst die Formel als Matrixformel eingeben, so wie ich es geschrieben habe mit STRG SHIFT und Enter die Formel bestätigen. Dann ziehst du die Formel einfach runter, sollte funktionieren, oder was meinst du

0
Hadi1987 21.07.2016, 12:33
@azmd108

Hab ich genau so gemacht, wie du es gesagt hast inkl. STRG + SHIFT und ENTER. Aber er soll ja die mehreren Werte, die in B stehen mir hier in einer Zelle ausgeben :/

0
azmd108 21.07.2016, 12:34
@Hadi1987

In EINER Zelle geht nicht ohne VBA-Programmierung. Mithilfe von Formeln geht es nur untereinander oder nebeneinander.

Was du machen könntest wäre die einzelnen, untereinander aufgelisteten ergebnisse so zu verknüpfen, ist aber undynamisch:


=A1&" "&A2&" "&A3

0
Hadi1987 21.07.2016, 12:36
@azmd108

Ahh ok, gut. Aber jetzt ist noch meine Frage, warum er den Wert drunter angibt, quasi in C4 gefunden, aber B5 ausgegeben

0
azmd108 21.07.2016, 12:37
@Hadi1987

Verstehe dein Problem leider nicht, ohne die Mappe zu sehen, ist es sehr abstrakt. Kannst du die vllt hochladen und hier einen Link posten?

0
Hadi1987 21.07.2016, 12:39
@azmd108

Ok, ne habs jetzt. Hab einfach die Formel umgeändert. Da, wo du "-1" geschrieben hattest, hab ich "-2" gemacht und am Ende "+1" so passts. Vielen Dank

1
augsburgchris 21.07.2016, 13:16
@Hadi1987

Versuch mal das. Auch als Arrayformel eingeben mit Steuerung+Hochstelltaste+Eingabetaste abschließen

=WENNFEHLER(INDEX(A:A;KKLEINSTE(WENN(C$2:C$20="Dieter";ZEILE($2:$20));ZEILE(A1)));"")

1
Iamiam 21.07.2016, 13:45
@augsburgchris

@ A-Chris:Genau so! nur index(B:B... anstatt ...A:A..., weil die Texte ja in B:B stehen.

Schön, dass du jetzt wieder vermehrt eingreifst, hab Deine Antworten lange vermisst!

@ Hadi: -1 0der -2 kommt drauf an. wo die Formel steht.

1
augsburgchris 21.07.2016, 16:06
@Iamiam

Stimmt, mea culpa. Kommt davon wenn man die Formeln ohne Excel zusammenschreibt.

0

Was möchtest Du wissen?