Auslaufzeit bei Paketberechnung in Excel?

... komplette Frage anzeigen

2 Antworten

Wie soll das bei deiner Tabelle den mit der Paketlaufzeit denn klappen, du hast nirgends ein Kaufdatum hinterlegt.

Warum nimmt immer jeder die Spaltenbezeichnug bei den Bildern raus, habt ihr alle Angst das man euch eine passende Lösung präsentieren kann. Das raten wo was steht macht langsam echt keinen Spaß mehr.

Die beste Möglichkeit ist immer eine Muster Datei irgendwie hochzuladen, dann muß man nichts nachbauen und hat gleich alles vor Augen.

Antwort bewerten Vielen Dank für Deine Bewertung

Wenn jeder Tag eingetragen ist, geht es so (ich nehme an, die erste relevante Zeile ist die 6)

=SUMMENPRODUKT((A$6:A$1000<=A6)*(A$6:A$1000>A6-150)*(B$6:B$1000))

Das liefert je Zeile die Gesamtzahl der Pakete in den max. 150 letzten Tagen.

A6:A1000<=A6 -> nur Tage, die nicht in der Zukunft liegen
A6:A1000>A6-150 -> max. 150 Tage in die Vergangenheit

Da ich nicht genau erkenne, welche Spalte summiert werden soll, bin ich einfach von Spalte B ausgegangen. Das musst Du noch anpassen.

Wenn allerdings freie Tage dazwischen liegen, dann würde ich empfehlen, nicht Tag 1, 2, 3 zu verwenden, sondern ein konkretes Datum. Die Formel funktioniert auch damit.

Falls ich die Frage falsch verstanden habe und Du nicht für jede Zeile die Summe haben willst, ersetzt Du das <=A6 bzw. >A6-150 einfach mit

<=heute() bzw. >heute()-150
Das liefert dann einen Wert für die letzten 150 Tage.

 

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von shooter3009
26.10.2016, 19:15

Die Sache ist die: wo muss ich diese Befehle denn eintragen? - Sollte ein Paket nach 150 Tagen auslaufen, so soll es in der Spalte ''raus'' mit -1 erscheinen.

Zur verdeutlichung habe ich die Tabelle hier mal hochgeladen: http://filehorst.de/d/bioHIrwj

0

Was möchtest Du wissen?