Abgleichen in Excel?

...komplette Frage anzeigen

4 Antworten

=ZÄHLENWENN(D:E;B2)

Wenn größer 0 taucht der Suchbegriff in D oder E (oder beiden) auf

Wenn Du allerdings von Wildwuchs sprichst: Suchst Du nach exakten Übereinstimmungen (Zellinhalt B2 genau gleich wie in den Suchspalten) oder ist damit zu rechnen, dass bei den Namen noch weitere Texte stehen?


Antwort bewerten Vielen Dank für Deine Bewertung
2001HAL9000 07.04.2016, 11:20

Schon besser :) Wir kommen der Sache Näher!
Allerdings taucht wenn dann nur ein Teil des Titels auf
Wenn ich in B "Phillips DVD Player" habe geht es ja nur um Phillips.
Und die Marke kommt halt nur in det Tabelle einzeln vor.

Deshalb muss die Tabelle im Text gesucht werden .-.

Aber ich spöre, wir kommen der Sache Näher :)

0
2001HAL9000 07.04.2016, 11:27
@2001HAL9000

Ich habe es jetzt umgedreht

=ZÄHLENWENN(B2;D:E)

Allerdings bleibt das Problem, dass er jetzt nur eine 1 ausgibt, wenn die gesamte Tabelle in B2 vorkommt, können wir das nicht auf einzelne Zellen limitieren?

0
Ninombre 07.04.2016, 11:30
@2001HAL9000

Das klappt aus meiner Sicht mit Hilfsspalten, bspw. F und G

=WENN(D1="";"";WENNFEHLER(FINDEN(D1;$B$2);""))
=WENN(E1="";"";WENNFEHLER(FINDEN(E1;$B$2);""))

Dann

=WENN(SUMME(F:G)>0;"Gefunden";"Nicht gefunden")

Das liefert dann aber nicht nur für Philips Treffer, sondern auch wenn irgendwo DVD Player steht. Wenn das nicht sein darf, musst Du den Suchbegriff genauer eingrenzen. Steht der in B2 immer zu Beginn?

0
2001HAL9000 07.04.2016, 11:40
@Ninombre

Du musst das halt so sehen, dass in D und E alle Suchbegriffe stehen. Und ich herausfinden will ob einer davon in B2 vorkommt. Wenn das so ist lasse ich B2 unverändert, wenn das nicht so ist holt er sich von wo Anders die Markeund schriebt sie davor.

Allerdings habe ich das mit dem WENN und dem ergänzen schon programmiert. Es geht wirklich nur darum, dass die Suchbegriffe mit B2 abgleicht.

0
Ninombre 07.04.2016, 11:44
@2001HAL9000

Dann sollte die Lösung über Hilfsspalten funktionieren. Die Formeln in F und G entsprechend für alle gefüllten Zeilen kopieren und fertig.

Wenn die Groß-/Kleinschreibung noch ignoriert werden soll, dann statt FINDEN SUCHEN verwenden.

0
2001HAL9000 07.04.2016, 11:53
@Ninombre

Danke, Deine Lösung mit den Hilfsspalten ist auf Jeden Fall schonmal eine der besten Ideen bisher. Allerdings wird die Tabelle später mit ~20.000 Artickeln gefüllt. (Also Spalte B). Das sind viele Hilfsspalten, die sich nicht wirklich automatisieren lassen...

Um Ehrlich zu sein geschehen die Berechnungen jeweils im entsprechenden B Feld, die eigentlichen Titel liegen im B-Fald auf einer Anderen Tabelle, aber das macht die Frage zu aufgeblasen, das kann ich nachher selber ergänzen.

0

=SVERWEIS("Can1.o";Tabelle2!H:J;3;FALSCH)

Antwort bewerten Vielen Dank für Deine Bewertung
2001HAL9000 07.04.2016, 11:08

Das klingt abenteuerlich aber gut, ich probiere es gleich mal aus und versuche es dann zu verstehen ^^
Danke schonmal!

1
Ninombre 07.04.2016, 11:16
@2001HAL9000

das funktioniert so eher nicht, weil in Spalte H gesucht und das Ergebnis aus Spalte J ausgegeben wird.

0
FragaAntworta 07.04.2016, 11:19
@Ninombre

Oho, natürlich funkioniert das, es muss nur angepasst werden, das wollte der FS selber machen, hat ja extra darauf hingewiesen. Und mit ein bisschen bedingter Formatierung kann er das Ergebnis dann auch farbig herausheben. Das Du es nicht erkennst und mit einer Zählewenn Funktion versehen willst, zeigt doch eher, dass Du gar nicht weißt was eine Suchfunktion oder eben auch SVERWEIS ist.

0
2001HAL9000 07.04.2016, 11:25
@FragaAntworta

Bei manchen Produkten steht halt ein Markenname im Titel, bei Anderen nicht.

Mein Ziel ist halt, dass die Tabelle nur den Markennamen vor einem Produkt (in B2) ergänzt, wenn da nicht schon einer steht. In E und D Stehen die Markennamen, in B die Titel (Um es zu vereinfachen bleiben wir mal bei B2)

0
FragaAntworta 07.04.2016, 11:29
@2001HAL9000

2001Hal9000, genau dafür ist diese Funktion da, sie zeigt Dir an wo es übereinstimmt, und mit bedingter Formatierung kannst Du es auch farblich anzeigen lassen. Also gehe dem Link nach und versuche es mit dieser Formel, ich bin sicher das es damit geht. Wenn Du allerdings jetzt auch noch eine Ergänzung mit einbauen willst, also den Namen erweitern, dann wirst Du mit "verketten" weiterkommen.

https://support.office.com/de-de/article/VERKETTEN-Funktion-8F8AE884-2CA8-4F7A-B093-75D702BEA31D

Wenn ich Dich richtig verstanden habe, willst Du doch erstmal wissen, wo was vorkommt, wenn Du einen Begriff eingiebst. Dass lässt sich mit SVERWEIS Prüfen.

0
2001HAL9000 07.04.2016, 11:46
@FragaAntworta

Hey FragaAntworta, ich glaube, Du hast mein Problem nicht 100 pro verstanden.

Wenn ich einen Produktnamen eingebe steht mal der Markenname mit drin und mal nicht. Ich droppe es in B2.
In D und E stehen die ganzen Markennamen.
Jetzt brauche ich nur eine Formel, die mir zurückgibt ob da ein Markenname im Titel steht Ja / Nein.

Wenn ja, dann bleibt der Titel unverändert, wenn nein packe ich die Marke über eine andere Formel, die ich schon fertig habe dazu.

0
2001HAL9000 07.04.2016, 12:01
@2001HAL9000

Gibt es nicht die Möglichkeit

=SUCHEN(D:E;B2)

so zu ergänzen, dass er schon ausschlägt, wenn nur eine der Zelleninhalte im Text von B2 vorkommt?

0

Gibt es nicht die Möglichkeit

=SUCHEN(D:E;B2)

so zu ergänzen, dass er schon ausschlägt, wenn nur eine der Zelleninhalte im Text von B2 vorkommt?

Antwort bewerten Vielen Dank für Deine Bewertung

Hat noch jemand einen Vorschlag?

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?