Ich benötige eine Excel Formel. Und zwar möchte das in einer Zeile "Jubiläumstag" erscheint, wenn folgendes Datum erfolgt und das auch noch in Farbe?

... komplette Frage anzeigen

5 Antworten

Mit dieser Formel:

=WENN("2.5.16"*1=HEUTE();"Jubiläumstag";HEUTE())

Nimm dazu noch dieses Ben-def. Format:

TTT, T.M.JJ h:mm;[Rot]-0;[Farbe7]°;[Farbe13]@

Das erspart Dir eine bedingte Formatierung: es stellt den Text "Jubiläumstag" in dunkelmagenta dar, einen positiven Wert als Datum (heute()), einen negativen als -rote Zahl, eine Null als magentafarbigen Grad-Kringel. Am besten alles in Arial rounded MT bold.

Hebe dieses Format auf, es erlaubt nämlich noch was anderes: Du kannst damit negative Zeiten berechnen, ohne dass ein Zeit- /Datums-Fehler dargestellt wird (normalerweise erlaubt xl ja keine negativen Zeiten im 1.1.1900er Modus!) (Die Darstellung der negativen Zeiten ist allerdings dann nur die reine -Zahl). Den vorderen Teil kannst Du nach Bedarf variieren, die Farben auch.

À propos Farben: Die Zahlen stammen aus dem uralten xl5 (da warens noch 40, wenn ich nicht irre), wurden in xl97 neu positioniert (und auf 56 erweitert) und sind weiterhin so in Bendef. Formaten ansprechbar

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Iamiam
01.05.2016, 00:43

ich hab noch ein besseres Format gebastelt: Benutzer-definiert

[Blau][>42490]TT.MM.JJ;[>=0]#.##0,00;[Rot]#.##0,00;[Farbe13]@

oder

[Blau][>42490]TT.MM.JJ;[>=0]Standard;[Rot]Standard;[Farbe13]@

Diese stellen eine Zahl größer als "30.4.16"*1 (also Tage in der Zukunft) als blaues Datum dar, Zahlen kleiner (incl. 0) als Standard oder mit zwei Dezimalen und Tausender-Trennpunkt dar, negative Zahlen rot und mit - sowie Texte definitiv in Farbe 13 (du-magenta). Die Farbe der positiven Zahlen bis zum Datum kannst Du frei wählen. Beim Datum kannst Du natürlich Farbe und Anzeigeformat anders einstellen (oder Farbe gar nicht vorgeben)

Da Zahlen über 42.000 im privaten Bereich selten vorkommen, sollte das ausreichend Spielraum eröffenen. Nicht geeignet dagegen für BetriebsBuchführung und Hypothekendarlehensberechnung.

Ich bin dabei, eine Unzahl von Formaten aus verschiedenen Dateien zu sammeln und werde die Datei samt den alten Farben dann mal hochladen, ich melde mich, wenn ich soweit bin.

0

Da fehlt tatsächlich noch etwas Info zur Frage.

Soll das wirklich nur angezeigt werden, wenn genau der Tag erreicht ist? Ich hätte spontan gesagt, anzeigen, wenn es auf den Monat genau ist, da das Datum ggf. ja auch auf ein Wochenende fallen könnte und dann hast Du es nie gesehen. Auf Monatsbasis mit Zusatzinfo welcher Tag es ganeu wäre ginge so:

Annahme: In A1 steht das Anfangsdatum (Geburtstag, Beginn Mitgliedschaft oder was auch immer) und es wird auf 10 Jahre geprüft (=120 Monate)

=WENN(HEUTE()=EDATUM(A1;120);"10. Jubiläum am: "&TAG(A1)&"."&MONAT(A1)&".";"")

Wenn nur der Text farbig sein soll, kannst Du (wie schon in der anderen Antwort genannt) einfach eine Textfarbe in die betroffenen Zellen setzen, die wird ja nur sichtbar, wenn was drin steht.

Ansonsten eine bedingte Formatierung - Formel =A1<>""

Antwort bewerten Vielen Dank für Deine Bewertung

Zu wenig Information

Also unter welchen Umständen soll "Jubiläumstag" da stehen?
Wenn ein Datum einer anderen Zelle das aktuelle ist?
Sozusagen eine Anzeige ob die Person Geburtstag hat?

dann wäre es in einer anderen Zelle etwas wie

=WENN(E2=HEUTE();"Jubiläumstag";" ")
E2 ist die Zelle in der das Datum steht
Heute() ist das heutige Datum deines Systems
"Jubiläumstag" kommt wenn beides gleich ist
" " ist drin weil sonst in der Zelle "FALSCH" steht wenn man es weglässt und es nicht gleich ist

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von thlu1
29.04.2016, 08:49

So hätte ich es auch gelöst und für die Farbe sorgt eine bedingte Formatierung auf den Textinhalt.

1

Hallo,

es gibt auch folgende (einfache) Lösung.

z. B. in A1 Dein Bezug (also steht dort das Datum, wann der Jubiläumstag ist).

In A2, =HEUTE().

In A3 folgende Formel: =WENN($A$2=$A$1;"Jubiläumstag";""). Den Jubiläumstag in A1 kannst Du jederzeit verändern, zudem kannst du diese Formel in beliebige Zellen kopieren ($-Zeichen nicht vergessen).

Gruß Tron

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von hilfemarie1993
07.05.2016, 16:42

Und welche Formel gebe ich ein, wenn ich die Anzahl der verbleibenden Tage bis zum Jubiläum haben möchte? Und dann die verbleibende Tage rot markiert haben möchte ?

Vielen Dank :)

0

Und wo genau liegt nun dein eigentliches Problem?

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?