Frage von slowlydriftin, 30

Zelle in Excel soll verstrichene Dauer seit Bestellung anzeigen und soll aufhören zu zählen, sobald Lieferung eingegangen ist?

Hallo zusammen,

ich bräuchte dringend ein Excel-Genie :(

Situation:

Spalte A zeigt Auftragsdatum der Bestellung an

Spalte B zeigt an "Lieferung eingegangen" bzw. "noch ausstehend"

Spalte C soll die verstrichene Zeit seit der Bestellung anzeigen, wobei aufgehört werden soll mit Zählen, sobald in Spalte B "Lieferung eingegangen" steht.

Wie man die verstrichene Zeit angibt weiß ich, nämlich =HEUTE() - Spalte A.

Also heutiges Datum abzüglich Bestelldatum aus Spalte A.

Aber wie mache ich das, dass es aufhört, die Zeit zu zählen, wenn in Spalte B "Leiferung eingegangen" steht?

Hilfe! :( Ich bin am verzweifeln, brauche aber ein Ergebnis für meinen Chef :(

Expertenantwort
von Iamiam, Community-Experte für Excel, 17

abgesehen von meiner Bemerkung bei Ninombre würde ich Dir empfehlen, nicht "Lieferung eingegangen" als Zelleintrag,

sondern eine Spaltenüberschrift "Lieferung eingegangen am" verwenden.
Schlag diese Form mal Deinem Chef vor, ob das akzeptabel wäre, verschone ihn mit den folgenden Einzelheiten, wenn er nicht danach fragt sondern argumentiere einfach nur: ..weils wesentlich einfacher ist.

Du kannst dann das zB als Vorgabe -NICHT per Dropdown- eingetragene "noch_ausstehend" ersetzen durch den äusserst schnellen Shortcut

Strg plus(gleichzeitig) Punkt , also Strg. ersetzen. Dieser Shortcut trägt das fixierte heutige Datum ein.

Stellst du das Datumsformat 14.3.01 ein (zB einmalig für die gesamte Spalte), so wird das auch in diesem Format dargestellt, ansonsten im längeren Format 14.03.2001)

Wenn es um juristisch relevante Post geht, kannst du sogar mit Strg. leer Strg:

zusätzlich die Uhrzeit der Registrierung festhalten, das aber nur, wenn's sofort geschieht..

Die Differenz liefert dann für jede Lieferung auch im Nachhinein die effektive Lieferfrist (wobei man Auswerteformeln beliebig kompliziert machen kann, wenn man auch Wochenenden und Feiertage rausrechnen will)

Kommentar von Ninombre ,

Die Anmerkungen von Iamiam sind eine wichtige Ergänzung: Wenn es bei der Tabelle anscheinend darum geht, Fristen zu überprüfen, kommt vermutlich bald auch die Frage, bei welchem Lieferanten es wie lange dauert. Um das zu beantworten ist es sinnvoll, direkt das Lieferdatum zu erfassen. Die Information, ob geliefert wurde, ist damit ja auch abgedeckt.

Antwort
von PWolff, 13

=WENN(B:B="Lieferung eingegangen";"";HEUTE()-A:A)

erfordert natürlich einen "magischen" Text - Tippfehler sind katastrophal.

Eleganter wäre es, wenn in Spalte B garantiert nichts drin steht, wenn die Lieferung nicht eingegangen ist (und ggf. das Datum des Liefereingangs):

=WENN(B:B<>"";"";HEUTE()-A:A)

Im Fall von Datum:

=WENN(ISTZAHL(B:B);"";HEUTE()-A:A)

(ISTDATUM scheint es leider nicht zu geben - jedenfalls wenigstens bis Version 2010 - und das, obwohl VBA die Funktion "IsDate" schon seit spätestens 1999 kennt)

Kommentar von slowlydriftin ,

Vielen Dank für deine Antwort! Auch deine (erste) Formel habe ich ausprobiert, es klappt. ABER: Mit deiner Formel bleibt die Zelle, die die verstrichene Zeit seit der Bestellung misst, leer, wenn der Status auf "Lieferung eingegangen" ist. Ich möchte aber, dass da dann trotzdem die verstrichene Zeit drin steht, nur dass aufgehört wird zu zählen, sobald die "Lieferung eingegangen" ist...

Kommentar von slowlydriftin ,

Ich glaube, ich habe die Lösung gefunden. Danke :)

Kommentar von PWolff ,

Auch wenn du die Lösung inzwischen gefunden hast - vielleicht schaut später nochmal jemand hier hinein:

Wenn die Zählung aufhören soll, wenn die Lieferung eingegangen ist, muss

- entweder das Lieferungsdatum in Spalte B eingetragen werden (Wenn man will, kann man die Zellen immer noch so formatieren, dass ein Datum als "Lieferung eingegangen" angezeigt wird - oder als "Lieferung eingegangen am " gefolgt vom Daum)

- oder die aktuelle Zählung in der Zelle festgehalten werden, sobald in Spalte B "Lieferung eingegangen" eingetragen wird - das erfordert aber ein Makro

Expertenantwort
von Ninombre, Community-Experte für Excel, 11

genie-status ist nicht unbedingt erforderlich, es reicht eine Wenn-Formel

=WENN(B2<>"Lieferung eingegangen";HEUTE()-A2;"")

Du könntest zusätzlich zur Anzeige noch mit einer bedingten Formatierung bei Überschreiten einer bestimmten Frist die Zelle bspw. rot färben

Kommentar von Iamiam ,

Das "Lieferung eingegangen" und "noch ausstehend" per Dropdown festzulegen vermeidet Schreibfehler.

Wenn Du aber immer festhalten willst, wie lange die Lieferung im Einzelfall gedauert hat, gedauert hat, reicht das nicht !

Kommentar von PWolff ,

Tipp für das Dropdown:

man kann über Daten -> Datenüberprüfung eine Liste angeben, sodass diese Liste als Dropdown angezeigt wird und nur Einträge aus dieser Liste möglich sind:

Man markiert die Spalte (oder allgemeiner den Zellbereich), für den diese Einschränkung gelten soll

Man wählt Daten -> Datenüberprüfung (oder Daten -> Datenüberprüfung -> Datenüberprüfung ...)

Unter "Zulassen" wählt man "Liste"

Unter "Quelle" gibt man entweder einen Zellbereich an, in dem die gewünschten Einträge stehen, oder man trägt die Einträge direkt ein, durch Semikolons getrennt - in diesem Beispiel:

Lieferung ausstehend;Lieferung eingegangen

Kommentar von slowlydriftin ,

Vielen Dank für deine Antwort! Ich habe es ausprobiert, es klappt. ABER: Mit deiner Formel bleibt die Zelle, die die verstrichene Zeit seit der Bestellung misst, leer, wenn der Status auf "Lieferung eingegangen" ist. Ich möchte aber, dass da dann trotzdem die verstrichene Zeit drin steht, nur dass aufgehört wird zu zählen...

Kommentar von slowlydriftin ,

Ich glaube, ich habe die Lösung gefunden :) Danke

Keine passende Antwort gefunden?

Fragen Sie die Community