Zählfunktion Excel?

... komplette Frage anzeigen

4 Antworten

Ich weiss nicht, ob ich dich richtig verstanden habe, aber mit ZÄHLENWENN kannst du Zellen Zählen, die einen bestimmten Inhalt haben.

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von lemonred94
02.09.2016, 18:18

Grundsätzlich funktioniert ZÄHLENWENN.

Das Problem besteht allerdings darin das nur einen Teil aus der Spalte als Kriterium heranziehen möchte und nicht die ganze Spalte.

Also alle dreistelligen Zahlen, alle vierstelligen Zahlen usw.

0

Der Ansatz von DeeDee07 mit summenprodukt hat mich auf eine Idee gebracht. Eigentlich wollte ich finden("/") mit wahr/falsch in die Formel bringen, das funktioniert aber nicht wie gedacht. Wenn die Produktnummern aber nicht mehr Varianten haben als im Beispiel genannt, wäre eine Unterscheidung aber auch so möglich:

=SUMMENPRODUKT((LÄNGE(C2:C20)=5)*ISTTEXT(C2:C20))
Liefert die 1/123 und ähnliche Werte bei denen ein / enthalten ist, was den Zellinhalt eben zum Text macht

statt isttext kann man auch istzahl setzen, dann werden die Werte mit Länge 5 ohne das / ermittelt

Antwort bewerten Vielen Dank für Deine Bewertung

Eine Zweidimensionale Übersicht erhältst Du so:

Hilfsspalten erforderlich, können später woandes hin, 2 über die gesamte Listenlänge

Voraussetzung : max reine Zahl oder ZahlenLabel: 99999 (sicherheitshalber eins mehr als lt. Liste gebraucht)

gemischt:Y/XXXXX Y<=9, Y◄>0,  X<=99999 (könnte erweitert werden)

Füge vor A:A 13 Spalten ein (Breite 9 genügt), kannst Du später woanders hin migrieren. Das alte A:A ist jetzt N:N, das alte C:C ist P:P. Sind bei Zoom=100% noch alle sichtbar. danach oberhalb noch eine Zeile.

In A2 tippst Du 0, in B2 1 und erweiterst das bis K=10, das sind die  auszuwertenden späteren Stellen (bei Länge Prod.Nr.=7 erforderlich). In L2: ◄Rechenstellen  G1:K1 füllst Du mit 3..7, in L1: ◄Stellen in Liste. G1:K1 fett, G2:L2 kleinere Schrift oder blasse SchriftFarbe (alles nur zur besseren Übersicht).

in A3 ebenfalls 1 und erweitern bis 9 in A11. in A12: erstes Z.

in B12:K12 dieses; 1.22 333 4444 55555 '1/1 '2/22 '3/333 '4/4444 '5/55555

die Hochkommata im zweiten Teil, damit kein (am.) Datum draus wird.

Jetzt die Hilfsspalten füllen:

  • in M3: =WENN(ISTFEHLER(FINDEN("/";P3;1));P3*1;TEIL(P3;3;9)*10^5) 
  • Mit Doppelklick aufs Ausfüllkästchen kopiert sich die Formel bis zum Ende der Liste.
  • Gleiches in L3: =LINKS(P3)*1

so vorbereitet lautet die Auswerteformel in B3:

=SUMMENPRODUKT(($L:$L=$A3)*($M:$M>=10^A$2)*($M:$M<10^B$2))

Bevor Du das kopierst, folgendes Bendef ZahlenFormat: 0;[Rot]-0;[Farbe7]"٠"

(ist universell brauchbar, wenn große Zahl an Nullen die Übersicht stört)

B3 kopieren bis K11 (erst Zeile füllen, dann runterziehen oder umgekehrt)

links bis incl. Sp.F stehen jetzt die Anzahl der reinen Zahlen, die mit der Zahl in Sp.B beginnen und der Größe(=Länge) B2:F2 entsprechend B12:F12

in G3:K11 stehen die summierten Einträge, die mit Y/ beginnen entsprechend Y = B3:B11 und der Länge entsprechend G1:K1 oder G12:K12.

zur optischen Abtrennung kannst du zwischen F1:F12 und G1:G12 eine Doppelte Rahmenlinie ziehen.

Bei Rückfragen melde Dich, aber auch sonst wäre es mir wichtig, zu erfahren, ob das brauchbar oder aber total abgehoben empfunden wird!

PS: die dicken violetten Balken im linken Teil sind ein anderes Bendef Format mit ▬ anstatt der indischen Null ٠

Die ◄ habe ich ersatzweise für < eingefügt, wei das oft Schwierigkeiten macht,

Antwort bewerten Vielen Dank für Deine Bewertung

Mit der Formel

=SUMMENPRODUKT((LÄNGE(C$2:C$99)=ZEILE(A1))*1)

erhälst du die Anzahl der Zellen in C2:C99, die genau 1 Zeichen lang sind. Wenn du sie runterkopierst, zeigt es an, wieviele Einträge 2 Zeichen lang, 3 Zeichen lang usw. sind.

Allerdings unterscheidet die Formel nicht zwischen XXXX und 1/XX, da gleiche Zeichenanzahl.

Du könntest mit der Funktion Text in Spalten (Menü Daten) die Artikelnummern trennen, mit dem / als Trennzeichen.  Dann kannst du die Summenproduktformel erweitern um die einspaltigen von den zweispaltigen Artikelnummern zu unterscheiden.

Antwort bewerten Vielen Dank für Deine Bewertung

Was möchtest Du wissen?