Frage von Linuxfg, 46

Youtube Videos werden verzerrt bzw. Teile des Videos werden verschoben (Ubuntu/Linux). Was soll ich tun?

Hallo zusammen.

Die Videos auf Youtube (generell im Browser und in den Video Player) werden zum teil "verzerrt" angezeigt. Genauer kann ich es nicht beschreiben, daher lade ich ein Bild hoch damit ihr euch einen Überblick verschaffen könnt. Sobald ich das Video pausiere wo die Verzerrung entsteht und ich im Vollbildmodus rein oder raus gehe, verschwindet die Verzerrung wieder. Das selbe passiert wenn ich das Fenster bis nach ganz unten bzw. den Rand bewege wo es nicht mehr sichtbar ist. Das passiert mit dem Flash Player genauso wie mit HTML5. Liegt es vielleicht an meine Grafikkarte oder an die Treiber? Hat jemand eine Idee wie ich das beheben kann, so dass es nicht mehr so angezeigt wird? Momentan habe ich Ubuntu 16.04 installiert, das gleiche Problem hatte ich jedenfalls auch bei Linux Mint 18... Mit Windows läuft ansonsten alles ganz normal. Falls jemand mehr Informationen benötigt wie Graka, Ram etc. einfach Bescheid sagen :) Danke schon mal im Voraus :D

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von LemyDanger57, Community-Experte für Linux & Ubuntu, 28

Wäre schon nicht schlecht gewesen, wenn Du die Grafikkarte gleich genannt hättest. Jetzt musst du selbst ein wenig suchen:

https://wiki.ubuntuusers.de/Grafikkarten/

Du könntest es mal mit einem anderen als dem standardmäßig installierten Grafiktreiber-Modul versuchen, such Dir auf der angegeben Seite denn zu Deiner Grafikkarte passenden Link und lies Dir den entsprechenden Artikel durch.

Kommentar von Linuxfg ,

Vielen Dank für deine Antowrt :D
Ich werde es gleich mal ausprobieren :)

Kommentar von Linuxfg ,

Ich habe mich durch den Artikel geklickt, komme aber nicht wirklich weiter. Ich verstehe nicht viel von dem was da steht. Ich habe den Befehl " lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2 " eingegeben und das ist dabei raus gekommen:

00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09)
    Subsystem: Lenovo Broadwell-U Integrated Graphics [17aa:3824]
    Kernel driver in use: i915
--
04:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] [1002:6820] (rev ff)
    Kernel driver in use: radeon
    Kernel modules: radeon

Ich weiss nicht woher ich jetzt einen alternativen Grafiktreiber her bekommen soll. Ich hab schon länger danach gegoogelt, finde jedoch nichts... Könnte mir da eventuell jemand weiterhelfen? Danke schon mal im Voraus :)

Kommentar von LemyDanger57 ,

OK, Du hast also einen Intel-Grafikchip. Hast Du dann mal auf den Link im Artikel geklickt und bist zu diesem Artikel gelangt: https://wiki.ubuntuusers.de/Grafikkarten/Intel/

?

Da steht ja drin, dass einerseits die Unterstützung durch Intel gut ist, aber andererseits die Leistung der Grafikchips eher schlecht ist.

Kommentar von Linuxfg ,

  Um ehrlich zu sein, habe ich auf AMD geklickt...
Nun bin ich auf https://wiki.ubuntuusers.de/Video-Dekodierung_beschleunigen/#Systeme-mit-Intel-G... gegangen und habe bei " Systeme mit Intel-Grafik " auf Jetzt installieren geklickt. Ich hab den Computer neu gestartet, hat sich aber nicht wirklich etwas getan.

  Ja das steht da, aber was genau bedeutet das für mich und wie soll ich jetzt weiter voran gehen? (Ich habe nicht wirklich viel Ahnung davon)

Kommentar von LemyDanger57 ,

Unten drunter steht doch auch noch etwas von VDPAU Unterstützimg, installiere das auch noch.

Und hast Du mal den Test gemacht?

Aber mal zwei adere Fragem: Ist das ein PC oder Laptop? Und hast Du eventuell zwei Grafikkarten eingebaut, einmal die im Prozessor integrierte Intel und auch noch eine AMD?

Dann solltest Du mal in dem zuerst henannten Artikel den Abschnitt über Hybridgrafikkarten anschauen!

Kommentar von Linuxfg ,

VDPAU habe ich ebenfalls installiert, hat aber nichts gebracht...

Der Test von VA API hat das angezeigt was auch beim Artikel steht (Das zweite Fenster).

Der Test von VDPAU hat folgendes angezeigt:

display: :0   screen: 0
libva info: VA-API version 0.39.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_0_39
libva info: va_openDriver() returns 0
API version: 1
Information string: OpenGL/VAAPI/libswscale backend for VDPAU

Video surface:

name   width height types
-------------------------------------------
420     1920  1080  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8
422     1920  1080  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8
444     1920  1080  NV12 YV12 UYVY YUYV Y8U8V8A8 V8U8Y8A8

Decoder capabilities:

name                        level macbs width height
----------------------------------------------------
(Beim Rest steht nur "Not supported". Es waren zu viele Zeichen, daher musste ich einen Teil von hier entfernen).
H264_BASELINE                  51 16384  2048  2048
H264_MAIN                      51 16384  2048  2048
H264_HIGH                      51 16384  2048  2048

H264_CONSTRAINED_BASELINE      51 16384  2048  2048

Output surface:

name              width height nat types
----------------------------------------------------
B8G8R8A8          8192  8192    y 
R8G8B8A8          8192  8192    y 
R10G10B10A2       8192  8192    y 
B10G10R10A2       8192  8192    y 
A8                8192  8192    y 

Bitmap surface:

name              width height
------------------------------
B8G8R8A8          8192  8192
R8G8B8A8          8192  8192
R10G10B10A2       8192  8192
B10G10R10A2       8192  8192
A8                8192  8192

Video mixer:

feature name                    sup
------------------------------------
DEINTERLACE_TEMPORAL             -
DEINTERLACE_TEMPORAL_SPATIAL     -
INVERSE_TELECINE                 -
NOISE_REDUCTION                  -
SHARPNESS                        -
LUMA_KEY                         -
HIGH QUALITY SCALING - L1        -
HIGH QUALITY SCALING - L2        -
HIGH QUALITY SCALING - L3        -
HIGH QUALITY SCALING - L4        -
HIGH QUALITY SCALING - L5        -
HIGH QUALITY SCALING - L6        -
HIGH QUALITY SCALING - L7        -
HIGH QUALITY SCALING - L8        -
HIGH QUALITY SCALING - L9        -

parameter name                  sup      min      max
-----------------------------------------------------
VIDEO_SURFACE_WIDTH              - 
VIDEO_SURFACE_HEIGHT             - 
CHROMA_TYPE                      - 
LAYERS                           - 

attribute name                  sup      min      max
-----------------------------------------------------
BACKGROUND_COLOR                 - 
CSC_MATRIX                       - 
NOISE_REDUCTION_LEVEL            - 
SHARPNESS_LEVEL                  - 
LUMA_KEY_MIN_LUMA                - 
LUMA_KEY_MAX_LUMA                - 

Es ist ein Laptop und eine AMD ist auch eingebaut.
(Ein AMD Radeon Graphics aufkleber ist vorhanden)

Welche genau eingebaut ist sollte hier stehen:

[AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X]

Ich habe mich auf diesen Artikel durch geklickt und bin auf der AMD-Homepage gelandet. Leider steht dort folgendes:

Distributions supported:

Ubuntu 12.04.4 LTS, 14.04.2, 14.04.3, 15.04, 15.10

Ubuntu 16.04 LTS wird scheinbar nicht unterstützt.

Macht es hier vielleicht Sinn genau das zu tun was Unter Intel-GPU aktivieren steht zu tun?

https://wiki.ubuntuusers.de/Hybrid-Grafikkarten/AMD_Hybrid-Grafikkarten_unter_fg...

Eher nicht oder? Denn unter Informationen (Einstellungen von Ubuntu) steht bei Grafik " Intel® HD Graphics 5500 (Broadwell GT2) ". Also nutzt das Laptop schon die Intel-GPU, oder sehe ich das falsch?

Ansonsten weiss ich mal wieder nicht weiter...

Kommentar von LemyDanger57 ,

Da die Intel Grafik wohl die schlechtere ist, könnte es helfen, wenn Du mal auf die AMD umschaltest. Das steht in dem von Dir zuletzt zitierten Artikel, ganz am Ende:

Wechsel zwischen den GPUs mittels fglrx¶

Zum Wechseln gibt es die zwei Befehle, die mit Administrator-Rechten [3] im Terminal [1] behandelt werden:

sudo aticonfig --px-dgpu  

Wechselt zur diskreten GPU nach einem An- und Abmelden. Diese wird von AMD als APU bezeichnet.

sudo aticonfig --px-igpu  

Wechselt zur intregrierten GPU (Stromsparmodus) nach einem An- und Abmelden des Benutzers.

Also den ersten Befehl eingeben und Dich dann Ab. und wieder anmelden (nicht neustarten).

Kommentar von Linuxfg ,

Danke dass du dich weiterhin bemühst mir zu helfen. Leider hat das nicht geklappt... Da steht nur dass der Befehl nicht gefunden wurde. Wahrscheinlich muss ich das tun was in diesem Artikel steht:

https://wiki.ubuntuusers.de/Grafikkarten/AMD/fglrx/Manuelle_Treiberinstallation/

Leider kriege ich keinen Treiber von der AMD-Homepage.
Ich habe die AMD Radeon (TM) R9 M375

Die Manuelle Treiber Suche geht bei leider nicht, daher weiss ich nicht woher ich einen Treiber her bekommen soll und vor allem welchen Treiber ich brauche, falls er in der Homepage vorhanden sein sollte... Irgend eine Idee? Googeln hat mir da nicht weiter geholfen.

Kommentar von LemyDanger57 ,

eher nicht, Du musst schon das machen, was bei hybrid-Karten steht, denn Du hast ja sowohl einen Intel-Grafikchip als auch eine AMD-Grafikkarte in dem Laptop. Ich bin mir da nicht sicher, was passiert, wenn Du den AMD-Treiber installierst. Aber probiere es aus, den Treiber findest Du hier:http://support.amd.com/de-de/download/linux

bei " Radeon™ R9 Fury, R9 300, and R7 300 Series"

Mir ist auch noch etwas eingefallen, Du könntest es ja auch mal mit einem anderen Browser versuchen, und zwar mit dem "Google Chrome", nicht "Chromium"!

Allerdings gibt es den nur auf der Google-Seite zum Download.



Kommentar von Linuxfg ,

Nun, Ubuntu 16.04 LTS Wird nicht unterstützt... Ich versuche schon Stunden das Problem zu lösen. In diesem Video wird erklärt dass es länger keine Unterstützung für Ubuntu 16.04 LTS geben wird.

https://www.youtube.com/watch?v=-Ed6_kz0d_I

Kann ich sonst noch irgendwas anderes versuchen oder muss ich auf das Betriebssystem verzichten?

Falls ich darauf verzichten muss, gibt es eine gute Alternative zu dem wo diese Sache mit den Videos nicht passiert?

Auf jeden Fall, Danke noch mal für die ganze mühe :)

Kommentar von LemyDanger57 ,

Ob das Problem mit dem AMD-Treiber wirklich verschwindet, ist leider nicht sicher, aber wenn Du es versuchen willst, kannst Du ja eine unterstützte Distribution installieren, eventuell als Dualboot-Installation. Ubuntu 14.04.2 wäre eine denkbare Alternative, benutze ich auch noch (als Ubuntu Studio, 16.04 ist noch nicht draußen). Das ist ja auch eine LTS mit Unterstützung bis 2019.

Wenn Du keine Dualboot-Installation machen willst/kannst, könntest Du es auch auf einem USB-Stick installieren ()Achtung! Dabei muss GRUB auf dem Stick installiert werden, nicht auf de Festplatte, sonst funktioniert der PC nur noch mit eingestecktem Stick!9 Hier findest Du eine Anleitung: https://wiki.ubuntuusers.de/Installation_auf_externen_Speichermedien/

Kommentar von Linuxfg ,

Alles klar, ich versuche es dann mit eine andere Distribution. Vielen dank für deine Hilfe :)

Antwort
von EvilMastermind, 45

Also das erste was ich definitiv mal machen würde ist nen anderen Browser probieren.

Kommentar von Linuxfg ,

Danke für deine Antwort :)
Ich habe das mit Firefox und mit Opera versucht. Bei beide Browser das gleiche Problem :/

Keine passende Antwort gefunden?

Fragen Sie die Community