Frage von Hager11, 291

Wlan-Repeater verteilt falsche IP-Adressen?

Hi,

seit ich einen Wlan Repeater habe, habe ich hin und wieder mal Probleme mit dem WLAN. Das liegt daran, dass der Repeater meinem PC eine 169.... IP zuteilt, mein Router aber nur 192.... IP Adressen erlaubt/verteilt. Bis gestern konnte man das Problem durch einen Neustart des Repeaters lösen. Nun geht dies aber nicht, egal ob man ihn neustartet, man bekommt keine Internetverbindung, da keine IP zugeteilt werden kann.

Es handelt sich beim Repeater entweder um den devolo Wifi Repeater oder um den Fritz! WLAN Repeater N/G (bei beiden ist das gleiche Problem vorhanden). Der Router ist der Speedport W742V.

Da es bei beiden Repeater zu dem gleichen Problem kommt, denke ich, dass es am Router liegt aber was muss ich ändern.

Mac-Filter etc. ist deaktiviert bzw. so eingestellt wie es die Anleitung möchte.

Hoffe jemand weiß eine Lösung.

Ergänzung: Fritz Repeater bekommt eine IP: 192.168.178.2
Router lässt aber nur von 192.168.2.100 - 192.168.2.199 zu

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von franzhartwig, 200

Ein Repeater verteilt keine IP-Adressen. Der Adressbereich 169.254.x.y wird von einem Betriebssystem selbst gewählt, wenn die automatische Adresszuweisung (DHCP) nicht funktioniert. Der DHCP-Server ist in der Regel der Router. Von dort kommen die IP-Adressen. Entweder bekommt der Router die Anfrage des Rechners nicht oder aber die Antwort kommt beim Rechner nicht an. Du hast wahrscheinlich ein Problem mit der Kommunikation zwischen Repeater und Router.

Der Fritz-Repeater hat die 192.168.178.2 nicht bekommen, sondern wohl statisch konfiguriert. 192.168.178.x ist der typische Bereich für AVM-Geräte. Zunächst einmal solltest Du dem Repeater die 192.168.2.2 geben. Nur so hast Du auch vernünftige Möglichkeiten, auf die Konfigurationsoberfläche zuzugreifen.

Anschließend solltest Du auf dem Router und dem Repeater schauen, ob beide miteinander per WLAN verbunden sind.

Kommentar von Hager11 ,

Wie kann ich dem Repeater die den Zuweisen? Er ist weder in der Liste von der Speedport gelistet noch kann ich irgendwie auf ihn zugreifen.

Kommentar von franzhartwig ,

Du musst Deinem Rechner vorübergehend statisch eine passende IP-Adresse geben, z.B. 192.168.178.100, Subnetzmaske 255.255.255.0, Gateway kannst Du frei lassen. Verbinde Dich mit dem WLAN des Repeaters und gib im Browser die Adresse 192.168.178.2 ein. Für weitere Schritte hilft das Handbuch.

Kommentar von Hager11 ,

Danke. Konnte dadurch die Mac Adresse im Router einspeichern. Hatte er nicht automatisch gemacht und auf einmal läuft alles perfekt.

Vielen Dank für deine Hilfe

Antwort
von Smexah, 199

Das Problem ist nicht der Repeater, die 169. ist meisten ein Defaultwert von Windows.

Dein Repeater  "verlängert" nur die Reichweite deines Netzes und vergibt im Normalfall  keine IPs.

Ich denke, das dein IP pool oder sonst was der Schuldige ist. Verbinde dich doch mal direkt mit dem Router. Dann kannste die Repeater ausschließen. 

Kommentar von Hager11 ,

Bin momentan direkt ohne Repeater verbunden. Das klappt auch. 

Router ist ein Stock über meinem PC aber noch ein Stock tiefer hat man kein Signal mehr und da brauch ich halt den Repeater und da klappt das nicht.

Kommentar von asdundab ,

Das von @Smexah beschriebene Problem tritt auch dann auf, wenn der Repeater zu schlechten, oder garkeinen Empfang hat.

Kommentar von Hager11 ,

Er bekommt vollen Empfang also alle 3 bzw 4 Balken sind da.

Kommentar von Smexah ,

Ach das ist merkwürdig und leider ohne davor zu sitzen schwer zu debuggen :(

Meine einzige Vermutung ist das die Koppelung zwischen Repeater und Router villt. zu locker ist. Ab und zu reißt die ab, aber das WLAN zwischen PC und Repeater bleibt bestehen. Da er aber nicht auf den DHCP der Routers zugreifen kann, gibts Probleme. 

Wie du geschrieben hast, hast du eine Statische IP für den Router verwendet, das ist schon gut. Du kannst auch noch die IP an die MAC binden im Router.

Was auch sein kann, aber normalerweise selten: Die Kanäle! Es kann sein das sich zwei WLANs (hässliches Wort) einen Kanal teilen wollen, dass führt zu abrissen und miesen Datenraten trotz vollem Empfang.

Antwort
von Dontknow0815, 151

Sowas tritt oft auf wenn 2 dhcps in einen lan sind. Eventuell hat dein Repeater einen.
Ich habe alle statisch vergeben da man da auf die wenigsten Probleme stößt.

Keine passende Antwort gefunden?

Fragen Sie die Community