Frage von Logyceck, 40

Windowswahl beim Booten hat ein Bug, wie krieg ich den weg?

Hallo alle zusammen,

um meine Frage zu verstehen bedarf es erst mal eine Vorgeschichte. :D

Ich habe mir einen Mini-PC zusammengebaut, welcher selber kein DVD-Laufwerk besitzt. Also habe ich die SSD vom Mini-PC, auf der das OS (Win7) installiert werden soll, an meinen großen PC , welcher ein internes Laufwerk besitzt, angeschlossen. Die SSD von dem großen PC habe ich für die Installation raus gesteckt. Nachdem die Installation vom OS auf der SSD vom Mini-PC erfolgreich beendet wurde, habe ich die SSD wieder an den Mini-PC angeschlossen und die SSD vom großen Rechner wieder am großen Rechner. Nun habe ich das Problem, dass der Mini-PC kein OS findet und mein großer Rechner gleich zwei, welche er mir beim Booten zur Auswahl gibt. (Der Win von der SSD des Mini-PCs, welche gar nicht mehr angeschlossen ist und dementsprechend nicht funktioniert und der alte, eigentliche Win, welcher beim wählen normal funktioniert.)

Ich weiß nicht wieso das geschehen ist, ich habe das schon sehr oft gemacht und der Computer hat sich nie "gemerkt" ob iwo ein OS installiert war, oder nicht. Er hat immer automatisch mit dem gearbeitet, welches gerade anschlossen war.

Habe das interne Laufwerk vom großen PC an den Mini-PC angeschlossen und dort nochmal den Win installiert und dort tut jetzt auch alles ordnungsgemäß. Mein Problem ist jedoch, dass mein großer Rechner mich beim Booten immer auffordert zwischen zwei Win's zu wählen, obwohl es einen davon gar nicht mehr gibt.

Und jetzt wirds ganz lustig: Mein großer Rechner hat noch eine HDD, welche aber nichts mit dem OS, welches sich auf der SSD befindet, zu tun hat. Stecke ich diese HDD aus, sagt mir der große PC, dass er nichts zum Booten findet, obwohl die SSD mit dem OS immer noch angeschlossen ist. Schließe ich de HDD wieder an erkennt das BIOS auch wieder die SSD und noch den Win, welcher gar nicht mehr da ist.

Wahrscheinlich handelt es sich hier um einen großen Bug... Meine Frage ist: Wie krieg ich den "falschen" Win-Eintrag weg? Wo kann ich dem BIOS sagen, dass es einen Win nicht mehr erkennen soll. Ich will nämlich nicht bei jedem PC-Start zwischen einen nicht vorhandenen und einen vorhandenen OS wählen. :D

Sorry wegen den Roman, ist aber glaub ich wichtig zum Verstehen des Problems.

Freue mich schon auf die Antworten! :)

Mit freundlichen Grüßen Logyceck

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von compu60, Community-Experte für Computer & PC, 26

Ein Bug ist das wahrscheinlich nicht. Bei deinem PC wurde anscheinend ein Teil des Bootmanagers auf der 2 Festplatte abgelegt. Darum sind jetzt 2 WIndows auf dem PC und kein Bootmanager auf dem MiniPC. Beim PC kannst du den 2. WIndows eintrag über msconfig löschen.

Kommentar von Logyceck ,

Danke für deine Antwort! Die HDD hatte aber bei dem ganzen Vorgang nichts zu tun gehabt. Ich habe ja bei der Win-Installation die neue SSD (vom Mini-PC) als Installationsort gewählt. Verwende oft msconfig, aber ich wusste nicht, dass man sowas damit machen kann. Das ist ja quasi eine Anwendung, welche erst greift, wenn der Windows startet. (Dachte ich jedenfalls, scheinbar falsch gedacht. :D) 

Werde es mal versuchen, danke! :)

Kommentar von compu60 ,

Das hängt nicht davon ab welchen Installationsort du wählst, sondern davon in welcher Reihenfolge die SSD und HDD am SATA-Kontroller angeschlossen sind. Die Ports sind nummeriert. Wenn jetzt die HDD Beispielsweise am Port 1 hängt und SSD an Port 2 installiert Windows die Bootdateien oft auf die HDD weil die am 1.Port hängt.

Kommentar von Logyceck ,

Wieso nicht auf dem selben Speicher wie der Win-Installationsort? Das ist doch eher hinderlich, wenn alles kunterbunt verteilt ist..

Kommentar von compu60 ,

Darum sollte ja die Systemfestplatte mit Windows an Port 1 stecken damit das nicht passiert.

Expertenantwort
von medmonk, Community-Experte für Computer, 20

Eines Vorweg, Windows sollte immer auf der Hardware installiert werden, auf der es laufen soll. Diese »Umsteckerei« der einzelnen Festplatten nur unnötig Probleme verursacht. Nun zu deinem eigentlich Problem. Warum jetzt zwei Einträge vorhanden sind, so auch nicht nachvollziehen kann. Zumal, wie du schreibst, die jeweilige Festplatte getrennt wurde. 

Verwendest du zufällig ein recht neues Mainboard mit UEFI? Wie dem auch sei. Lade dir EasyBCD ( http://neosmart.net/EasyBCD/ ) herunter und lösche darüber den unnötigen Eintrag im Bootmenü. Danach sollte alles wieder beim alten sein.  Alternativ mit Bordmitteln (msconfig) korrigieren. 

Kommentar von Logyceck ,

Danke für die Antwort! Ja ich mache das auch ungern. Nur wollt ich nicht extra das interne Laufwerk raus schrauben. Kam aber letztendlich nicht drum herum. Der große PC hat ein UEFI BIOS, das andere ist ganz neu (1151 Slot, DDR4, etc.) läuft aber glaub ich auch mit UEFI.

Danke für den Link! Ich werde es gleich mal ausprobieren. :)

Kommentar von Logyceck ,

*1151 Sockel 

Keine passende Antwort gefunden?

Fragen Sie die Community