Frage von alluuuuu, 57

Wieso klappt folgende Formel nicht?

=WENN(UND(A11="A";B11="4");"1";WENN(UND(A11="B";B11<>"3");"1.25";WENN(UND(A11="B";B11="3");"1.5")))

Auswahl in A11: A; B Auswahl in B11: 2; 3; 4 Möglichkeiten im angestrebten Feld (C11): 1; 1.25; 1.5

Wenn in A11 B steht, kommt in C11 immer 1.25, egal was in B11 steht. Wenn in A11 A steht, kommt immer "Falsch". Was stimmt mit der Formel nicht?

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 23

Lass die Anführungszeichen bei den Zahlen weg, dann sollte es klappen. Die sind nur bei Texten notwendig bzw. ein Vergleich <> geht nur bei Zahlen.


Kommentar von alluuuuu ,

Das war die Lösung! Danke viel mal!

Expertenantwort
von DeeDee07, Community-Experte für Excel, 27

Wie ist B11 formatiert? Als Standard, Text oder anders? Versuch mal, die Anführungszeichen bei den B11-Prüfungen zu löschen (also =4 statt ="4" usw.). "Falsch" erscheint, weil du keine Sonst-Anweisung in der 3. Wenn-Schachtel hast.

Antwort
von sonnedessuedens, 38

Ich programmiere, aber nicht in dieser Sprache (Excel?). M.E. müssen die Klammern, die UND(...) umgeben geschlossen werden:

=WENN(UND(...));"1" .. und nicht erst am Ende.

Kommentar von alluuuuu ,

Funktioniert leider auch dann nicht :(

Antwort
von TysonAlex, 34

Alphabetisch gesehen kommt gewoehnlicherweise der Buchstabe D als naechstes

Kommentar von alluuuuu ,

Wo meinst du sollte Buchstaben D folgen? in A11? da steht D nicht zur Auswahl, nur A und B.

Antwort
von loveyax, 6

Wie heißt das thema :O

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten