Frage von niklug, 74

Wieso erkennt Excel meine Formel nicht?

Ich habe folgende Formel eingegeben:

=WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Januar.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ");WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Februar.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 März.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 April.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Mai.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Juni.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Juli.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 August.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 September.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Oktober.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 November.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ";WENNFEHLER((SVERWEIS(A3;'C:\Users\Nicolas\Documents\KuE\Controlllisten[Auswertung 22-6 Dezember.xlsx]Standardbericht Mitarbeiterante'!$B$2:$M$397;2;FALSCH)=" ");" "))))))))))))))))))))))

und bekomme die Fehlermeldung, die mich fragt, ob ich überhaupt eine Formel eingeben will.

Any suggestions?

Expertenantwort
von Ninombre, Community-Experte für Excel, 32

Vielleicht wäre es mit Hilfsspalten einfacher und v.a. übersichtlicher:
Je Monat also eine Zelle mit SVERWEIS oder WENNFEHLER(SVERWEIS) und dann den Wert nehmen, der nicht #NV bzw. leer ist.

Deine Formel wird ja auch nur dann fehlerfrei liefern, wenn der Wert nur in einer Datei auftaucht, Mehrfachtreffer sollte es nicht geben.

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 49

Meine Suggestion ist, dass du die WENNFEHLERs einzeln testest.

Solltest du keinen Fehler feststellen können, ist wahrscheinlich die Formel zu lang. Dann musst du sie stückeln.

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten