Frage von Totenzeichen, 54

Wie Zähle ich Zahlen in OpenOffice?

Erst mal ein nettes Hallo, nennt mich ein OpenOffice Amateur das bin ich scheinbar, ich brauche Hilfe, im Moment ist mein Problem das ich nicht weiß, wie ich in einer Spalte die Anzahl von Zahlen zähle. Ich möchte quasi in meiner Tabelle die Summen bzw. Zahlen zählen die in einer bestimmten Spalte vorhanden sind (z. B. steht in Zeile B2 die Summe 24€ und in Zeile B5 die Summe 90€ das zusammen soll 2 Ergeben es sind 2 Zahlen in Spalte B eingetragen, und dies soll mir in einem einzigen Feld in z. B. dem Feld XY angegeben werden) probiert hatte ich es mit z. B. (=ZÄHLENWENN (B2:B5;"Zahl") doch das hat nicht Funktioniert ein Blick in die Hilfe (F1) hat mich ebenfalls nicht voran gebracht dasselbe galt für die Google suche die mehr als genug Unbrauchbare Ergebnisse lieferte

Ich Danke schon mal

mfg; Totenzeichen

Antwort vom Steuerberater online erhalten
Anzeige

Schnelle und günstige Hilfe für Ihre Steuerfrage. Kompetent, von geprüften Steuerberatern.

Experten fragen

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Iamiam, 28

dafür gibts die Formel

=Anzahl(Bereich)

zählt alle Zahlen im Bereich

=Anzahl2(Bereich) zählt alle Einträge, also Texte+Zahlen

(nun frag bloß nicht nach der Zahl der Kommentare...)

Kommentar von Totenzeichen ,

Vielen Dank für die rasche Hilfe, das hat mir wirklich sehr Geholfen.

Mit freundlichen Grüßen Totenzeichen

Kommentar von Iamiam ,

danke für den * !

Es gibt übrigens auch noch =ANZAHLLEEREZELLEN(bereich), sowohl in OO/LO wie auch in xl.

Aber Vorsicht: da werden auch Zellen als leer mitgezählt, die das Formelergebnis leer liefern, im einfachsten Fall ="" !

Im Gegensatz dazu zählt die Einzelzellauswertung von =Istleer(Zelle) solche Zellen NICHT als LEER, , das Ergebnis "" liefert also FALSCH.

Könnte sein, dass das gerade wegen der Differenzierung der beiden 

Zustände so eingeführt wurde. Gibt noch eine Menge anderer Möglichkeiten, zB kann man mit verschiedenen Konstellationen in Summenprodukt spielen:

  • =SUMMENPRODUKT((H8:H14="")*1)
  • =SUMMENPRODUKT(ISTZAHL(H8:H14)*1)
  • =SUMMENPRODUKT((H8:H14=0)*ISTZAHL(H8:H14))
  • =SUMMENPRODUKT((H8:H14=0)*NICHT(ISTZAHL(H8:H14)))
  • es nist nicht unbedingt vorhersehbar, welche Ergebnisse da geliefert werden von einer ="" -Formel. "" ist jedenfalls keine Zahl, sondern ein (leerer) Text. Der Teufel ist ein Eichhörnchen, auch in xl!
Antwort
von dkilli, 39

Hoffentlich habe ich dich richtig verstanden. In der Spalte stehen manchmal Zahlen  und manchmal nichts oder es ist Text vorhanden. Nun möchtest du wissen, wie oft stehen in der Spalte  Zahlen drin. 

Dann gib in einer Zelle 

=SUMME(WENN(ISTZAHL(B1:B8);1;0))

ein. Nur das ist eine Array Formel. Die darfst du nicht einfach mit Enter abschließen!!! Drücke die Tasten Strg & Shift (Großschreibtaste) & Enter.

Dann lautet die Formel

{=SUMME(WENN(ISTZAHL(B1:B8);1;0))}

Die geschweiften Klammern werden automatisch hinzugefügt! 

An Stelle von B1:B8 musst du natürlich den Bereich eingaben, wo gezählt werden soll. Wenn du dort B:B eingibst, so wird in der gesamten spalte gezählt.  

Kommentar von Totenzeichen ,

Vielen Dank für die rasche Hilfe, das hat mir wirklich sehr Geholfen.

Mit freundlichen Grüßen Totenzeichen

Kommentar von dkilli ,

Entspricht das Ergebnis deinen Vorstellungen???

Keine passende Antwort gefunden?

Fragen Sie die Community