Frage von Jonalii, 52

Wie vergleiche Werte in einer Exceltabelle?

Hallo zusammen,

mein Problem ist folgendes: ich habe eine Nahrungsmitteltabelle erstellt. 1.Spalte Text, 2. Spalte KH, 3. Spalte Kalorien. Nun möchte ich einen Tagesplan erstellen und immer wenn ich ein bestimmtes Nahrungsmittel eingebe, soll in der Tabelle danach gesucht werden und die betreffenden Werte (KH bzw. Kalorien) in eine dafür vorgesehene Zelle gesetzt werden.

Ich würde mich freuen, wenn mir nette Experten helfen würden. Gruß Jonalii

Antwort
von ThisIsGu, 25

Das machst du mit SVERWEIS().

Du schreibst z.B. in die Zelle A1 was du suchst. In A3 kommt: SVERWEIS(A1,XX:XX,INDEX,0/1)

A1 steht für die Zelle wo das gesucht steht.

XX:XX dort gibst du die Tabelle bzw. den Bereich dieser an wo gesucht werden soll.

INDEX ist die Spalte in der Tabelle wo der Wert steht

Und 0/1 ist exakte Suche oder nicht. In deinem Fall auf 0 stellen. Auf 1 würde er wenn du zum Beispiel Salat suchst, aber keiner in der Tabelle steht den Kartoffelsalat anzeigen ;)

Und so machst du das halt für jede Tabellenspalte. Viel Glück!
Die Zellen und Formeln dann einfach nach unten kopierbar machen (Mit $) und schon kannst du deine Nahrungsmittel da reinschreiben :)

Kommentar von Jonalii ,

Vielen Dank für Deine schnelle Antwort. Leider funktioniert es nicht, weil ständig die Fehlermeldung #name? (was vermutlich nichts mit Deiner Formel zu tun hat). Ich habe schon herumexperimentiert, aber den Fehler noch nicht gefunden. Hast Du eine Idee?

Gruß

Jonalii

Kommentar von Ninombre ,

es kommt darauf an, wie Du die Formel konkret mit Werten belegt hast:
Statt , muss ; verwendet werden.
INDEX ist durch eine konkrete Zahl zu ersetzen, diese gibt an aus welcher Spalte im definierten Suchbereich das Ergebnis genommen wird. Hier z.B. gibt es 2 Spalten als Suchbereich: 2 wäre Spalte D, eben die 2. im Suchbereich.

=SVERWEIS(A1;C1:D100;2;FALSCH)

Das 0 und 1 ist aus meiner Sicht als wahr / falsch zu hinterlegen. Falsch heißt "genaue Übereinstimmung"

Antwort
von Jackie251, 21

Zunächst markierst du deine gesamte Nahrung (also die 1. Spalte und soweit runter das zumindest alles erfasst ist, ggf auch ein paar Leereilen.
dann klickst du in das Adressfeld (da wo die Adresse der aktuellen Zelle steht) und gibst der Tabellen einen Namen, ZBNahrung.

Jetzt markiertst du die beiten Spalten mit den Daten mit (in der Länge genausolang wie voher und vergibts den Name "Daten"

wenn nun in A1 ein Nahrungsmittel steht, bringen dich folgende Formeln zu den Kohlehydraten

=INDEX(Daten;VERGLEICH(A1;Nahrung;0);2)

bzw zu den Kalorien

=INDEX(Daten;VERGLEICH(A1;Nahrung;0);3)
Kommentar von Jonalii ,

Hallo Jackie251,

vielen Dank für Deine schnelle Antwort. Leider wird in der betreffenden Zelle (z.B. KH) nur  #nv  angezeigt. Weißt Du eine Lösung?

Gruß Jonalii

Kommentar von Jackie251 ,

Ja, du sucht ein Nahrungsmittel das nicht der Liste vorhanden ist.
Es muss exakt gleich geschrieben sein ohne Leerzeichen oder ähnliches

#nv bedeutet das Excel keine passenden Wert finden konnte

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten