Frage von Cyberping, 48

Wie schaffe ich es in Excel Monate halbjahresweise auf- bzw. abzurunden?

Hallo ich habe ein Datum: 01.12.2014 Hieraus habe ich mit DATEDIF die Differenz an Monaten zu heute ermittelt (21 Monate)

Nun möchte ich die Jahre ermitteln und zwar folgendermaßen:

Wenn die Differenz 13 Monate zu heute ist, soll 1 Jahr bei rauskommen. Wenn die Differenz aber 19 Monate beträgt soll er auf 2 Jahre aufrunden.

D.h. unter 6 Monate < abrunden über 6 Monate > aufrunden

Kann mir jmd. helfen? :)

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Suboptimierer, Community-Experte für Excel, 38

Runde doch auf volle 12 Monate mit VRUNDEN und teile das Ergebnis durch 12.

Kommentar von Cyberping ,

bei 21 Monaten kommen hier aber 2 Jahre anstatt 3 raus...

=VRUNDEN(I29/12;0)

Kommentar von Suboptimierer ,

Du sollst das Ergebnis durch 12 teilen, nicht innen schon das I29. ;)

=VRUNDEN(I29;12)/12
Kommentar von Suboptimierer ,

2 ist im übrigen das richtige Ergebnis. 21 Monate = 1 Jahr + 9 Monate. Die 9 Monate runden die Zahl auf 2 Jahre.

3 würde ab 30 Monate = 2 Jahre + 6 Monate heraus kommen.

Kommentar von Cyberping ,

Ich habs so gemacht 

=VRUNDEN(I29;12)/12

Das Ergebnis stimmt! Auch für andere Daten. Vielen Dank!

Kommentar von Suboptimierer ,

Bitteschön!

Expertenantwort
von DeeDee07, Community-Experte für Excel, 32

Mit der Formel
=RUNDEN(A1/12;0)
wobei hier in A1 die Anzahl der Monate steht

Kommentar von Cyberping ,

bei 21 Monaten kommt hier aber 2 Jahre anstatt 3 raus...

Kommentar von DeeDee07 ,

21 Monate sind 1 Jahr und 9 Monate, auf ganze Jahre gerundet also 2 Jahre.

Kommentar von iMPerFekTioN ,

Schon, aber sein Wunsch sind, das z.B. 18 Monate was ja 3+6 wäre, auch schon als 3 gezählt wird!

Kommentar von DeeDee07 ,

Wenn die Differenz aber 19 Monate beträgt soll er auf 2 Jahre aufrunden.

Das war der Wunsch.

Ich erkenne auch nicht den Zusammenhang zwischen 18 und 3+6

Antwort
von iMPerFekTioN, 13

Hallo,

A1 dein Datum:

01.12.2014

B1:

=DATEDIF(A1;HEUTE();"m")

C1:

=ABRUNDEN(B1/6;0)

Fertig!

Grüße,

iMPerFekTioN 

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten