Wie löse ich diese Informatik Aufgabe?

... komplette Frage anzeigen

1 Antwort

Es ist kein WENN enthalten, aber es ist ja nur ein Tipp und es müsste funktionieren.

Zahl steht in A1

Zahlen bis 2^15
=SUMMENPRODUKT(GANZZAHL(REST(A1/2^(SPALTE(A:Z)-1);2))*10^(SPALTE(A:Z)-1))

Zahlen bis 2^27
=RECHTS(SUMMENPRODUKT(GANZZAHL(REST(A1/2^(ZEILE(16:30)-1);2))*10^(ZEILE(1:15)-1))&TEXT(SUMMENPRODUKT(GANZZAHL(REST(A1/2^(ZEILE(1:15)-1);2))*10^(ZEILE(1:15)-1));WIEDERHOLEN("0";15));GANZZAHL(LN(A1)/LN(2))+1)

Antwort bewerten Vielen Dank für Deine Bewertung
Kommentar von Profchiller
15.09.2016, 09:43

Hm schein etwas zu komplex aufn ersten Blick, hiers viel kleiner

/**
* Methode, die eine Dezimalzahl in Binär umwandelt
* @param args
*/
public static void main(String[] args) {
int n = Integer.parseInt(args[0]);
String dual = " ";
while (n > 0){
dual = n % 2 + dual;
n = n / 2;
}
System.out.println(dual);
}

Scheint nur ne while(if()) kombi zu sein, aber dual=dual, weis nicht ob excel das kann

0

Was möchtest Du wissen?