Frage von nie592, 39

Wie lautet die korrekte Excel Formel?

Hallo Leute,

folgender Hintergrund: Ich habe in meiner Excel Arbeitsmappe zwei Arbeitsblätter. Im ersten Arbeitsblatt gibt es zwei Spalten. In der ersten Spalte sind die Artikelnummern aufgeführt und in der zweiten die bestellte Menge.

Im zweiten Arbeitsblatt gibt es ebenfalls zwei Spalten. Die erste ist hierbei wieder mit Artikelnummern gefüllt. In der zweiten Zeile steht jedoch dieses Mal nicht die bestellte Menge, sondern die Menge, die Menge, die der Artikel in seiner Standardverpackung hat. Als Beispiel zum besseren Verständis:

Mappe1: Artikelnummer: 1111 Bestellmenge: 2.800 Mappe 2: Artikelnummer: 1111 Menge in StandardVE: 3.000

Ich suche nun nach einer Formel, die mir in der Arbeitsmappe 1 anzeigt, ob nur volle Kartons verschickt wurden. D.h. wenn die Bestellmenge durch die Menge in Standardverpackung eine gerade Zahl ergibt. (z.B. 10.000 Bestellmenge / 5000 pro Karton = 2 volle Karton - 8.000 Bestellmenge / 5000 pro Karton = 1 voller Karton + Rest). Die Mengen sollte man ja wahrscheinlich mit dem SVerweis bekommen. Gut wäre es, wenn die Formel bei Rest eine 1 ergibt und bei keinem Rest eine 0 dargestellt wird.

Hoffe Ihr versteht mich. Vielen Dank vorab!

Gruß, nie592

Antwort
von gfntom, 21

Mit REST hast du es ja schon ganz gut getroffen ;)

=REST(Bestellmenge; VE)

gibt den Rest der Division Bestellmenge/VE an

Wenn du nur 0 oder 1 haben willst:

=WENN(REST(Bestellmenge; VE)>0;1;0)

Kommentar von nie592 ,

Hallo gfntom,

erst einmal Danke für deine Antwort! Hab den SVerweis noch eingefügt und es klappt so wirklich.

Formel sieht nun wie folgt aus:

=WENN(REST(C2;SVERWEIS(B2;StandardVE!A:B;2;FALSCH))>0;1;0)

Keine passende Antwort gefunden?

Fragen Sie die Community