Frage von kadurro, 74

Wie lautet die Formel bei Excel, wenn man in einer Spalte die Zahlen addieren will, welche an jeder 24. Position stehen?

Ich möchte gerne jede 24. Zahl in einer Spalte zusammenzählen lassen und brauche dafür eine Formel...

Danke im Voraus für die Antworten

Hilfreichste Antwort - ausgezeichnet vom Fragesteller
von Ninombre, Community-Experte für Excel, 37

Auf Basis dieser Anmerkung

Es zählt mit deiner Formel dann, wie viel es in jeder 24. Zeile
insgesamt ergibt, aber ich möchte ja nicht wissen, wie viel in jeder 24.
Zeile ist sondern wie viel in einer Spalte, auf der 24. Position

Es zählt mit deiner Formel dann, wie viel es in jeder 24. Zeile
insgesamt ergibt, aber ich möchte ja nicht wissen, wie viel in jeder 24.
Zeile ist sondern wie viel in einer Spalte, auf der 24. Position

noch mal ein neuer Anlauf bzw. Frage:

Soll ab der 24. Zahl dann in der Spalte weiter summiert werden, also gem. der Formel von Suboptimierer, nur dass man den Anfang (also die Zeile mit der ersten Zahl noch bestimmen muss)

Das wäre ggf. dies:
=SUMMENPRODUKT(A:A*(REST(ZEILE(A:A);24)=VERGLEICH(WAHR;A1:A1000<>"";0)))

Nach der Eingabe mit STRG+SHIFT+Enter abschließen, damit sich die {} für Matrixformeln bilden. Das ist also die Formel wie bisher nur der Beginn dynamisch

ODER

willst Du nur wissen, welche Zahl die 24. ist? Dann bräuchte man keine Summen bilden

ODER

willst Du über diverse Spalten die jeweils 24. Zahl aufaddieren?

Expertenantwort
von Suboptimierer, Community-Experte für Excel, 30

Wenn in Zeile 1 die erste Zahl steht, dann 

=SUMMENPRODUKT(A:A*(REST(ZEILE(A:A);24)=1))
Kommentar von kadurro ,

Ich hab schon einmal eine ähnliche Formel ausprobiert, das ist der Richtige Weg, aber das Resultat sollte 10 sein und mit deiner Formel gibt es mir 16...

Kommentar von Suboptimierer ,

Achte darauf, dass keine Zwischenergebnisse und Summen in der Spalte stehen und dass Zahlen in Kopfzeilen herausgerechnet werden.

Kommentar von kadurro ,

Da passt alles, ich hab nichts davon in meiner Tabelle...

Kommentar von Oubyi ,

Ich denke so sollte es klappen:
Wenn in Zeile 1 die erste Zahl steht, dann:

=SUMMENPRODUKT(A:A*(REST(ZEILE(A:A);24)=0))

Sonst den Wert nach dem =-Zeichen anpassen.
1 für Beginn in Zeile 2;
2 für Beginn in Zeile 3;
n für Beginn in Zeile n+1;
Vorsicht nur, wenn n > 24 wird.

Kommentar von Suboptimierer ,

Ich verstehe deinen Kommentar nicht.

Wenn in Zeile 1 in A1 die erste Zahl steht, dann gibt REST(ZEILE(A:A);24) eine 1 als Ergebnis, da 1/24 = 0 Rest 1 ist. Es muss auf =1 abgeprüft werden.

Die nächste zu addierende Zahl ist in Zeile 25. REST(ZEILE(A:A);24) gibt 1 als Ergebnis, da 25/24 = 1 Rest 1 ist. Auch hier muss auf =1 abgeprüft werden.

Ich sehe gerade nicht, weshalb man einen Versatz beim Zählen der Zeilen berücksichtigen sollte.

Kommentar von kadurro ,

Durch deine Formel besteht dann eine Abweichung von 8 zum Resultat, dass kann nicht sein und die 1. Zahl befindet sich im Feld C2

Kommentar von Suboptimierer ,

Wenn die erste Zahl sich in C2 befindet, lautet die Formel meiner Meinung nach:

=SUMMENPRODUKT(C:C*(REST(ZEILE(C:C);24)=2))

Es werden die Zahlen aus C2, C26, C50,... addiert.

Kommentar von Oubyi ,

Es werden die Zahlen aus C2, C26, C50,... addiert.

...und DA liegt unser "Problem".
Wenn C2 die erste Zahl ist, dann ist C25 die 24te Zahl!
Und C49 die 48te usw.
Und daher:
=SUMMENPRODUKT(C:C*(REST(ZEILE(C:C);24)=1))

Inzwischen verstehe ich allerdings auch nicht mehr, was der FS genau erreichen will.

Kommentar von kadurro ,

Es zählt mit deiner Formel dann, wie viel es in jeder 24. Zeile insgesamt ergibt, aber ich möchte ja nicht wissen, wie viel in jeder 24. Zeile ist sondern wie viel in einer Spalte, auf der 24. Position

Kommentar von Suboptimierer ,

Da bin ich überfragt.

Kommentar von nk1006 ,

das kommt selten vor

Keine passende Antwort gefunden?

Fragen Sie die Community

Weitere Fragen mit Antworten